Bug 525820 - smartd cannot send warning email because of missing privileges - smartd actually useless!
Summary: smartd cannot send warning email because of missing privileges - smartd actua...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: smartmontools
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 23:56 UTC by Ronald Wahl
Modified: 2009-10-27 08:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-27 08:11:07 UTC


Attachments (Terms of Use)

Description Ronald Wahl 2009-09-25 23:56:13 UTC
Description of problem:

When smartd sends warning emails it calls the mailer "mail" by default. "mail" itself tries dropping privileges but fails:

Executing test of mail to root ...
Test of mail to root produced unexpected output (66 bytes) to STDOUT/STDERR: 
drop_privileges: setgroups(1, 51) failed: Operation not permitted

... and no mail is actually sent.

This will cause admins detecting disk failures when it's already too late.

Version-Release number of selected component (if applicable):

smartmontools-5.38-13.fc11.i586

How reproducible:

Always

Steps to Reproduce:
1. stop smartd by calling "service smartd stop"
2. Add -M test to a device config in /etc/smard.conf, e.g.:

/dev/sda -d sat -H -l error -l selftest -t -I 9 -I 190 -I 194 -m root -M test

2. call "smartd -d -q onecheck" and watch the output
3. Check root's email
  
Actual results:

no email from smartd

Expected results:

email from smartd

Additional info:

Most probably caused by the "smartmontools-5.38-lowcap.patch".

Comment 1 Michal Hlavinka 2009-09-29 13:33:50 UTC
> Most probably caused by the "smartmontools-5.38-lowcap.patch".  

so this was working before update, right?

Comment 2 Ronald Wahl 2009-09-29 22:00:33 UTC
Yes. Just checked with smartmontools-5.38-11.fc11.i586.rpm.

Comment 3 Michal Hlavinka 2009-10-05 14:04:48 UTC
fixed in smartmontools-5.38-14.fc11

Comment 4 Fedora Update System 2009-10-05 14:46:32 UTC
smartmontools-5.38-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/smartmontools-5.38-14.fc11

Comment 5 Fedora Update System 2009-10-05 14:46:44 UTC
smartmontools-5.38-18.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/smartmontools-5.38-18.fc12

Comment 6 Fedora Update System 2009-10-27 06:43:50 UTC
smartmontools-5.38-18.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.