Bug 525821 - X server hang, Xorg consumes 100% CPU time
X server hang, Xorg consumes 100% CPU time
Status: CLOSED DUPLICATE of bug 528593
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 20:25 EDT by Christian Krause
Modified: 2009-11-01 18:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-01 18:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log including backtrace (57.07 KB, text/plain)
2009-09-25 20:25 EDT, Christian Krause
no flags Details

  None (edit)
Description Christian Krause 2009-09-25 20:25:28 EDT
Created attachment 362734 [details]
Xorg.0.log including backtrace

Description of problem:
- on my laptop with a ATI Radeon mobility HD 3400 the X server hangs after a couple of minutes
- the Xorg process consumes 100% CPU time
- nothing (no window, no panel, ...) is updated anymore
- mouse (static mouse cursor) can still be moved around

a backtrace is reported in /var/log/Xorg.0.log:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80a3c8c]
1: /usr/bin/Xorg (mieqEnqueue+0x1b7) [0x809c207]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xe4) [0x80bffd4]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0x18a000+0x3082) [0x18d082]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0x18a000+0x3376) [0x18d376]
5: /usr/bin/Xorg (0x8047000+0x6b980) [0x80b2980]
6: /usr/bin/Xorg (0x8047000+0x11e9a4) [0x81659a4]
7: (vdso) (__kernel_sigreturn+0x0) [0x7d9400]
8: (vdso) (__kernel_vsyscall+0x10) [0x7d9424]
9: /lib/libc.so.6 (ioctl+0x19) [0x92fd79]
10: /usr/lib/libdrm.so.2 (drmIoctl+0x2e) [0x79f088e]
11: /usr/lib/libdrm.so.2 (drmCommandWriteRead+0x3c) [0x79f0bbc]
12: /usr/lib/libdrm_radeon.so.1 (0x185000+0xc6a) [0x185c6a]
13: /usr/lib/libdrm_radeon.so.1 (0x185000+0xd8f) [0x185d8f]
14: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x203000+0xb67d1) [0x2b97d1]
15: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x203000+0xb6843) [0x2b9843]
16: /usr/lib/xorg/modules/drivers/radeon_drv.so (0x203000+0xb42c9) [0x2b72c9]
17: /usr/lib/xorg/modules/libexa.so (0xae4000+0x7988) [0xaeb988]
18: /usr/lib/xorg/modules/libexa.so (0xae4000+0x8563) [0xaec563]
19: /usr/bin/Xorg (0x8047000+0xd5016) [0x811c016]
20: /usr/bin/Xorg (0x8047000+0x24c40) [0x806bc40]
21: /usr/bin/Xorg (0x8047000+0x27137) [0x806e137]
22: /usr/bin/Xorg (0x8047000+0x1b885) [0x8062885]
23: /lib/libc.so.6 (__libc_start_main+0xe6) [0x870b36]
24: /usr/bin/Xorg (0x8047000+0x1b471) [0x8062471]


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.i686


How reproducible:
- happens all the time, but the time until it hangs differs

Steps to Reproduce:
1. start X
2. wait until X hangs
  
Additional info:
- no xorg.conf
- KMS on
- no messages in dmesg when the problem happens
- Xorg.0.log attached

If you need more information from me or if I should test / try out something, I'll be glad to help.
Comment 1 Jérôme Glisse 2009-10-21 17:24:19 EDT
Please upgrade to lastest fedora 12 bit and test again. If you still have this issue try adding pcie_aspm=off to kernel boot parameter to see if it helps.
Comment 2 Christian Krause 2009-10-21 17:45:33 EDT
I've retested the issue with a fully update rawhide/F12 system:

xorg-x11-drv-ati-6.13.0-0.7.20091006git457646d73.fc12.i686
kernel-PAE-2.6.31.1-56.fc12.i686

1. with KMS: problem still happens, backtrace still the same

2. with pcie_aspm=off: problem still happens with the same backtrace

3. without KMS: the issue does not happen
Comment 3 Jérôme Glisse 2009-10-28 15:06:54 EDT
Please try using kernel from :
http://koji.fedoraproject.org/koji/buildinfo?buildID=138707

And report back if it helps.
Comment 4 Christian Krause 2009-10-28 17:42:28 EDT
(In reply to comment #3)
> http://koji.fedoraproject.org/koji/buildinfo?buildID=138707

I've retested the issue:

kernel-PAE-2.6.31.5-104.fc12.i686
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.i686

1. with KMS: problem still happens, backtrace still the same

2. with pcie_aspm=off: problem still happens with the same backtrace

3. without KMS: the issue does not happen
Comment 5 Jérôme Glisse 2009-10-29 10:00:42 EDT
Please attach output dmesg after the problem happen.
Comment 6 Christian Krause 2009-10-29 16:32:03 EDT
There is nothing appended to dmesg after the problems occurs. Here are the last lines which were already there right after bootup:

[...]
CPU0 attaching NULL sched-domain.
CPU1 attaching NULL sched-domain.
CPU0 attaching sched-domain:
 domain 0: span 0-1 level MC
  groups: 0 1
CPU1 attaching sched-domain:
 domain 0: span 0-1 level MC
  groups: 1 0
eth0: no IPv6 routers present
fuse init (API version 7.12)
wlan0: authenticate with AP xx:xx:xx:xx:xx:xx
wlan0: authenticated
wlan0: associate with AP xx:xx:xx:xx:xx:xx
wlan0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
padlock: VIA PadLock not detected.
wlan0: no IPv6 routers present
Comment 7 Adam Williamson 2009-11-01 17:34:33 EST
Christian, could you please provide the output of 'lspci'? This is likely a dupe of 528593, but we need to know your motherboard chipset information to be entirely sure.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Christian Krause 2009-11-01 17:52:30 EST
Sure, no problem:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
Comment 9 Adam Williamson 2009-11-01 18:08:41 EST
Alright, you have the dreaded r600 + ICH9 combination, as I suspected. Marking as a dupe of 528593, where widespread reports of this kind of hanging with this hardware combination are being tracked. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 528593 ***

Note You need to log in before you can comment on or make changes to this bug.