Bug 525823 - All Samba connections rejected after update
Summary: All Samba connections rejected after update
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 01:17 UTC by Matt Castelein
Modified: 2010-06-28 14:48 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-28 14:48:53 UTC


Attachments (Terms of Use)

Description Matt Castelein 2009-09-26 01:17:52 UTC
Description of problem: Yum update today included samba packages:
Sep 25 10:13:21 Updated: samba-winbind-3.4.1-0.41.fc11.x86_64
Sep 25 10:13:24 Updated: samba-common-3.4.1-0.41.fc11.x86_64
Sep 25 10:13:26 Updated: samba-3.4.1-0.41.fc11.x86_64
Sep 25 10:13:29 Updated: samba-client-3.4.1-0.41.fc11.x86_64
Sep 25 10:13:30 Updated: libsmbclient-3.4.1-0.41.fc11.x86_64

After this update was installed no users can access shares.  Access denied for all users.  Webmin is telling me there ARE NO USERS, but a check of /var/lib/samba/private/smbpasswd shows they are still there.  Webmin is expecting the users file to be in /etc/samba/smbpasswd but this file is missing.  Restarting smb/nmb has no effect.

Comment 1 Simon Roberts 2009-09-26 06:52:55 UTC
I have the same.

Comment 2 Simon Roberts 2009-09-26 07:02:46 UTC
Removing all my site-configuration and reinstalling these RPMs didn't help (ie: 100% stock configuration doesn't work).  Clients are another F11 machine, and a mac desktop.

Rolling back to Samba 3.3.2-0.33 fixed problem.

Comment 3 Matt Castelein 2009-09-26 19:42:46 UTC
Yeah, rolling back fixed it for me too..

Comment 4 Egon Kastelijn 2009-09-27 20:05:41 UTC
I am having the same problem.
My /var/log/messages says:

smbd[8056]: [2009/09/27 21:59:55,  0] smbd/server.c:457(smbd_open_one_socket)
smbd[8056]:   smbd_open_once_socket: open_socket_in: Address already in use

And /var/log/samba/smbd.log says:
[2009/09/27 21:59:55,  0]  mbd/server.c:457(smbd_open_one_socket)
  smbd_open_onc _socket: open_socket_in: Address already in use

Comment 5 Robert Hoekstra 2009-09-28 07:13:55 UTC
fwiw, the i586 packages do not seem to be affected.

Comment 6 Guenther Deschner 2009-09-28 09:38:38 UTC

*** This bug has been marked as a duplicate of bug 525861 ***

Comment 7 Keith Robertson 2009-10-21 02:32:14 UTC
This bug and  525861 don't seem to be related to me.  I am having the problem on an x86_64 system with an "passdb backend = ldapsam:ldap:... blah blah" backend.

Comment 8 Keith Robertson 2009-10-21 02:33:33 UTC
(In reply to comment #7)
> This bug and  525861 don't seem to be related to me.  I am having the problem
> on an x86_64 system with an "passdb backend = ldapsam:ldap:... blah blah"
> backend.  

Forgot to mention that rolling back to 3.3.2-0.33 corrected the problem for me also.

Comment 9 Andrew McNabb 2010-03-15 20:44:24 UTC
I'm hitting this same error after upgrading from samba-3.4.5-55.fc12.x86_64 to samba-3.4.7-58.fc12.x86_64.  I also see no connection to bug #525861.  I think the duplicate status was a mistake; do you mind if I switch it to assigned?

Comment 10 Bug Zapper 2010-04-28 10:34:49 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Bug Zapper 2010-06-28 14:48:53 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.