Bug 52583 - KDE Sount Server failure with SB!Live
KDE Sount Server failure with SB!Live
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: kdemultimedia (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 16:55 EDT by Viral
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 16:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viral 2001-08-25 16:55:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
On login to KDE I often get the error message:
----------------------------------------------------------------------
Sound Server informational message:

error while initializing the Sound driver:

device /dev/dsp can't be opend (permission denied)

The sound server will continue, using the null output device.
----------------------------------------------------------------------

I am fairly sure this is related to aRts, as whenever I select "full
duplex" from the Kde Controll Pannel and "test sound" the controll pannel
locks up untill I force a kill command on the arts server.

This error wont happen all the time, and I cannot find any pattern to it,
but only on login as either a user or root..  Once this message has been
shown however programs like kmix and the kde cd player will crash (they are
loaded by default by my selecting "restore session" although dont appear to
be the cause of the sound server crash.

rebooting the machine is the only fix I have found.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.login
2.logout
3.login, it might happen, it might not
	

Actual Results:  Either it works, or gives the error, no pattern.

Expected Results:  it should of just worked!!!

Additional info:

I use a SoundBlaster Live 5.1 "Player" (I think player, but its a Europein
one, and outside the USA creative dont seem to find it nessacery to pretend
there is an actuall differeance between live products EXCEPT ofc the gold
plated ones =)
Comment 1 Bernhard Rosenkraenzer 2001-08-27 05:38:32 EDT
Works here (also some weirdo European SB Live). Make sure no other program is 
blocking the soundcard while artsd is starting up.
The full duplex setting works here, too, but this may well be a driver bug. No 
problems here on a SB Live (cheapest edition, whatever it may be ;) ), an ESS 
Maestro 3E, an ISA SB16 and an ESS1868.
Comment 2 Viral 2001-08-27 06:13:04 EDT
Well, I have installed nothing aside the redhat provided rpm's that are NOT 
standalone programs that afaik do not have any back ground processes, absolutly 
no third party daemons, yet it is garunteed to happen every time now..

I have tryed with and without things like mixer starting up on login, and also 
reverting all sound settings back to presets, nada!

Is there perhaps some log specificly that might help me elaborate on this?  I 
am fairly sure I have no done anything to cause this aside perhaps change 
settings in the distro..

Tonight I'll create blank accounts and have a go there as well, but as I said 
any specific log you might know of and I'll look thru it

Note You need to log in before you can comment on or make changes to this bug.