Bug 52584 - BigInteger is broken
BigInteger is broken
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kaffe (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 16:58 EDT by Need Real Name
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 17:36:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-25 16:58:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Programs that try to use the math.BigInteger class with kaffe will fail.  
The error produced is:

+ java Freenet.node.Node
java.lang.ExceptionInInitializerError: [exception was 
kaffe.util.SupportDisabled: GNU gmp was not found by Kaffe configure 
script]
        at java.lang.Class.forName(Class.java:native)
        at java.lang.Class.forName(Class.java:52)
kaffe.util.SupportDisabled: GNU gmp was not found by Kaffe configure script
        at java.lang.Throwable.fillInStackTrace(Throwable.java:native)
        at java.lang.Throwable.<init>(Throwable.java:38)
        at java.lang.Error.<init>(Error.java:21)
        at kaffe.util.SupportDisabled.<init>(SupportDisabled.java:22)
        at java.math.BigInteger.initialize0(BigInteger.java:native)
        at java.math.BigInteger.<clinit>(BigInteger.java:30)
        at Freenet.crypt.Yarrow.<init>(Yarrow.java:line unknown, pc 
0x81dfc3b)
        at Freenet.Core.<clinit>(Core.java:line unknown, pc 0x81df938)
        at java.lang.Class.forName(Class.java:native)
        at java.lang.Class.forName(Class.java:52)

Apparently, this is due to GMP detection failing during the RPM build, 
even though gmp and gmp-devel are installed.  Here is the error produced 
during the configure process for kaffe:

configure:4036: checking for mpz_get_d in -lgmp
configure:4048: warning: function declaration isn't a prototype
configure:4050: warning: function declaration isn't a prototype
/tmp/ccBRvnBf.o: In function `main':
/home/modus/rpm/BUILD/kaffe-1.0.6/configure:4051: undefined reference to 
`mpz_get_d'

This despite the fact that mpz_get_d is declared in the gmp.h header 
in /usr/include.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Kaffe
2.Install a java program that uses math.BigInteger (or build a small test)
3.Run the program
	

Actual Results:  See description

Expected Results:  See description

Additional info:
Comment 1 Need Real Name 2001-08-26 08:48:13 EDT
I just tested the Roswell SRPM.  It has the same problem.
Comment 2 Bill Nottingham 2004-12-17 17:36:30 EST
No longer shipped, closing.

Note You need to log in before you can comment on or make changes to this bug.