Bug 525862 - Hopelessly stuttering video after a few seconds
Hopelessly stuttering video after a few seconds
Status: CLOSED DUPLICATE of bug 523066
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-26 07:55 EDT by Nicolas Mailhot
Modified: 2009-10-07 07:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 07:04:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-09-26 07:55:01 EDT
Description of problem:

I have an Hauppauge WinTV PVR 150 video card. It can do lots of things but I only use it as a dumb svideo input to stream TV to the computer (yes it uses MPEG2, but show me an affordable PCI card that uses Theora or Dirac on the market; besides, it's legit even in legally-challenged countries since the hardware manufacturer paid the patent dues)

When I bought it it was perfectly supported by in-kernel drivers, I could do full-screen upscaled video with no stuttering and little CPU load, and everyone was happy.

During the past years the audio people first made it impossible to use it in full-screen mode, then made any attempt to move the window while playing a dangerous stutter-inducing operation. Finally it culminated to the point that just playing video for a dozen of seconds in an idle system without moving the window or doing anything else is sufficient for the video to start stutter and then rapidly degenerate till everything freezes.

Of course unlike with old 2000-ish non-realtime non-multicore non-lowlatency non-hpet really-slow-and-crappy systems the video never recovers and re-syncs again. You have to stop the program and re-load it to get a new 10s run or correct video

gst-launch playbin uri=file:///dev/video0
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

(gst-launch-0.10:4438): GStreamer-CRITICAL **: gst_event_new_new_segment_full: assertion `start != -1' failed
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstPulseSinkClock
WARNING: from element /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage: A lot of buffers are being dropped.
Additional debug info:
gstbasesink.c(2575): gst_base_sink_is_too_late (): /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage:
There may be a timestamping problem, or this computer is too slow.
WARNING: from element /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage: A lot of buffers are being dropped.
Additional debug info:
gstbasesink.c(2575): gst_base_sink_is_too_late (): /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage:
There may be a timestamping problem, or this computer is too slow.
WARNING: from element /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage: A lot of buffers are being dropped.
Additional debug info:
gstbasesink.c(2575): gst_base_sink_is_too_late (): /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage:
There may be a timestamping problem, or this computer is too slow.


mplayer stutters too a little but manages to maintain a steady state and does not freezes completely like gstreamer

$ mplayer /dev/video0
MPlayer 29092-4.4.0 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /dev/video0.
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  8000.0 kbps (1000.0 kbyte/s)
Opening video filter: [scale]
Opening video filter: [pp=hb/vb/dr/al/fd]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
[PP] Using external postprocessing filter, max q = 6.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[pulse] working around probably broken pause functionality,
        see http://www.pulseaudio.org/ticket/440
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
[PP] Using external postprocessing filter, max q = 6.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[swscaler @ 0xb6b120]using unscaled yuv420p -> yuv420p special converter
VO: [xv] 720x576 => 768x576 Planar YV12  [fs] [zoom]
A:  11.1 V:  10.7 A-V:  0.464 ct: -0.795 237/237  6%  8% 60.7% 76 0                                                                                                   

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************


Both apps blame the hardware, though it's a lie (cpu load never goes over 14%, this worked perfectly before, and I've replaced the mobo & CPU at least once with much more powerful components since I own this card).

I'm pretty sure that as always before removing pulseaudio from the audio path will restore the system to skip-free play capability.
Comment 1 Nicolas Mailhot 2009-09-26 07:58:58 EDT
gstreamer-0.10.24-1.fc12.x86_64
pulseaudio-0.9.18-1.fc12.x86_64
Comment 2 Nicolas Mailhot 2009-09-26 08:00:27 EDT
And it used to work under heavy system load, such as a series of background mock build
Comment 3 Bastien Nocera 2009-09-26 08:40:37 EDT
Looks like a problem with pulsesink.
Comment 4 Bastien Nocera 2009-10-07 07:04:24 EDT

*** This bug has been marked as a duplicate of bug 523066 ***

Note You need to log in before you can comment on or make changes to this bug.