Bug 525864 - New notifications are inconsistent in button presentation
Summary: New notifications are inconsistent in button presentation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: notification-daemon-engine-slider
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 12:14 UTC by Paul W. Frields
Modified: 2015-01-14 23:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-28 17:38:08 UTC


Attachments (Terms of Use)
a patch (1.10 KB, patch)
2009-09-28 01:09 UTC, Matthias Clasen
no flags Details | Diff

Description Paul W. Frields 2009-09-26 12:14:08 UTC
fedora-gnome-theme-12.3-1.fc12.noarch

The buttons in a bubble look like pencil art, and therefore it's not clear they're interactive.  I can't tell whether this is intentional or by design.

When I hover my mouse cursor over the "X" close button, it turns grey and beveled (i.e. button like), which helps me understand I can click it.  But when I hover the mouse over a "Dismiss" or "Show" button, they don't act the same, so it's confusing visually.  I would expect those buttons also to change appearance when I hover over them.

The black appearance does get my attention a bit faster.  I'm not sure it's visually pleasing but I guess the idea should be that if you're going to bother putting a notification up, it should really get my attention, and you'll promise to do that as little as possible unless I ask you to do otherwise.

Comment 1 Matthias Clasen 2009-09-27 05:12:50 UTC
I think you are right that all buttons should have the same prelighting behaviour.

Comment 2 Matthias Clasen 2009-09-28 01:09:09 UTC
Created attachment 362837 [details]
a patch

Here is a minimal patch to make the action buttons prelight in the same way as the close button.

Comment 3 Matthias Clasen 2009-09-28 17:38:08 UTC
Built in rawhide


Note You need to log in before you can comment on or make changes to this bug.