Bug 525873 - Support for cpuid masking per domU with Xen hypervisor
Summary: Support for cpuid masking per domU with Xen hypervisor
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: 5.6
Assignee: Xen Maintainance List
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
: 694492 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 14:19 UTC by Pasi Karkkainen
Modified: 2011-09-15 15:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-17 11:52:24 UTC


Attachments (Terms of Use)

Description Pasi Karkkainen 2009-09-26 14:19:35 UTC
Description of problem:

Xen hypervisor in RHEL5 doesn't support cpuid masking. It's a required feature for cross CPU-vendor live-migrations, and to work-around bugs in guest PV kernels, like for example:
https://bugzilla.redhat.com/show_bug.cgi?id=525290

Version-Release number of selected component (if applicable):
5.x

How reproducible:
This feature does not exist in RHEL5 Xen.

Additional info:
Support for CPUID masking was initially added in upstream Xen 3.3.0.
http://www.nabble.com/Xen-3.3-News:-3.3.0-release-available!-td19106008.html

Comment 5 Bill Burns 2010-03-17 11:52:24 UTC
Thanks for the request. But at this time we do not plan to add this support due to low demand and the invasiveness to our code base.

Comment 6 Chris Lalancette 2010-07-19 13:56:24 UTC
Clearing out old flags for reporting purposes.

Chris Lalancette

Comment 7 Laszlo Ersek 2011-09-15 15:11:03 UTC
*** Bug 694492 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.