Bug 52590 - consider tinycdb implementation
consider tinycdb implementation
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: dbskkd-cdb (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
ftp://ftp.corpit.ru/pub/tinycdb/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 20:30 EDT by Michael Tokarev
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 22:27:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Tokarev 2001-08-25 20:30:01 EDT
The above url points to (re-)implementation of DJB's cdb-0.75
library.  It doesn't contain his code.  It is easy to use.
It has some additional features (notably, ability to search
in to-be-written cdb).  Package contains single command-line
utility to manipulate cdb databases.  It is format- and API-
compatible with cdb-0.75.  It was in production for almost
a year now.

Note that freecdb currently based on earlier version of DJB's cdb,
with different API.

I contacted with Tommi about a library that will replace freecdb.
He mostly agreed, but unfortunately he has no time to work on
freecdb nor on replacement.  And I'm somewhat afraid of the fact
that there are 3 implementations already exists -- freecdb aka
DJB cdb-0.64, DJB cdb-0.75, and tinycdb -- way too many for this
little package.  This leads to a situation when any software
that uses cdb forced to include some implementation inside it's
sourcecode -- duplicating efforts and bugs.  DJB's variant is
almost unusable due to difficulties building/linking with library
(you need other his libs at link time).  Freecdb is somewhat obsolete
(while may be simpler).

Please take a look into this my implementation, and consider
adding it into RedHat distribution -- freecdb was added by a
purpose, yes?  One of topics we discussed with Tomi was that
currently, not many (if at all) other packages uses freecdb
as it is, so it is not too later to switch to more accurate
implementation.

BTW, I'm not a lawyer et al, and can't write "licence terms" --
I assumed that "public domain" is sufficient a a licence... ;)
Comment 1 Satoru SATOH 2001-08-28 05:41:55 EDT
Thanks!

I've been waiting for cdb clone for a long time
that is written from scratch as I can't agree 
DJB's thougt on the condition to distribute.

But unfortunately, currently, I'm sorry that 
I can't try to replace freecdb with your new one 
because now the development state comes into RC?
and I have less time to test it.

So I'll try to import your new library on next release.

Again, thanks for your kindness.
Comment 2 Jens Petersen 2002-03-11 03:08:10 EST
currently freecdb has been moved into dbskkd-cdb - the only package that uses it
- and is statically limited again it.  Public domain is not good enough for
inclusion it should be under an open source license.
Comment 3 Michael Tokarev 2002-03-11 05:38:55 EST
It's irrelevant for me whatether license to use for this code.  In
fact, I'm just lazy to write one or to mention that huge "This is
a free software..." in every source file... ;)  Moreover, in fact
I don't quite sure what "public domain" means! ;)  Well, I understand
that discussion of license terms does not belongs to this place (btw,
where it belongs to?).  Will it be better if this code will be released
under e.g. BSD license, or dual BSD/LGPL license?  I'm not a lawyer
etc, I've written this code because it is useful for me and because
it may be (and IS) useful for others.  But I don't want to restrict
usage of this code more than of original DJB's code.  And his code is
in "public domain".  (Consider me a total newbie in "the world of licenses":)

BTW, currently, this package provides old pre-cdb-0.75 query interface
as well (but not old cdb_make interface).  Also, I plan to include
nss module similar to nss_db -- it is almost ready, and perl interface.
Comment 4 Jens Petersen 2002-03-25 22:46:43 EST
Actually, sorry, public domain is probably ok too.
I'll try to take a look at this when I find some time.
Thanks.
Comment 5 Jens Petersen 2005-05-17 22:27:53 EDT
dbskkd-cdb is no longer a part of Fedora Core/devel.

I am sorry you have waited so long, however if you're still
interested, I suggest contributing tinycdb to Fedora Extras
which is actively accepting new packages.

Please see http://fedoraproject.org/wiki/Extras for more details.

Note You need to log in before you can comment on or make changes to this bug.