Bug 525907 - httpd isn't starting after apr upgrade to apr-1.3.9-1.fc12.x86_64 (XEN kernel)
Summary: httpd isn't starting after apr upgrade to apr-1.3.9-1.fc12.x86_64 (XEN kernel)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: apr
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 22:40 UTC by Kevin Schmidt
Modified: 2009-12-08 08:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-08 08:16:12 UTC


Attachments (Terms of Use)

Description Kevin Schmidt 2009-09-26 22:40:42 UTC
When I try to start httpd after upgrade to apr-1.3.9-1.fc12.x86_64 from apr-1.3.8-2.fc11.x86_64, it fails with output:

[root@test /]# service httpd start
Starting httpd: [Sat Sep 26 22:26:47 2009] [crit] (22)Invalid argument: alloc_listener: failed to get a socket for (null)
Syntax error on line 134 of /etc/httpd/conf/httpd.conf:
Listen setup failed
                                                           [FAILED]

/etc/httpd/conf/httpd.conf 134 is:
Listen 80

I'm running a kernel 2.6.24-24-xen on a XEN VM. It looks like this is similar to bug 516331, an older kernel missing certain functions for apr.

Steps to Reproduce:
1) service httpd start (starts ok)
2) service httpd stop
3) yum update apr (apr-1.3.8-2.fc11.x86_64 -> apr-1.3.9-1.fc12.x86_64)
4) service httpd start (fails)

Comment 1 Bojan Smojver 2009-09-27 03:49:40 UTC
You are correct - your kernel is too old. You should have at least 2.6.28.

Joe,

You want me to do anything with this or do we ask folks to upgrade their kernels?

Comment 2 Kevin Schmidt 2009-09-27 04:59:15 UTC
Just as a note, I can't upgrade my kernel, as I'm only renting a couple of XEN VMs from my provider and I'm already running the latest kernel they provide. I doubt I'm the only one that will be in this situation ...

Comment 3 Bojan Smojver 2009-09-27 05:18:58 UTC
Yeah, we've seen this situation before.

I'm just waiting for Joe to chime in on this. I bet he'll ask me to do what I did for F-11 - revert to using old calls.

Comment 4 Joe Orton 2009-09-28 11:09:31 UTC
Yes - I do think we should revert to using old system calls.

(it would be nice if there was a Fedora policy on what minimally supported kernel we should target, but I can't find one)

Comment 5 Bojan Smojver 2009-09-28 12:05:16 UTC
Building -2 now.

Comment 6 Bug Zapper 2009-11-16 13:00:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Joe Orton 2009-12-03 16:54:06 UTC
Can you confirm this is working with apr-1.3.9-3?

Comment 8 Kevin Schmidt 2009-12-08 02:40:14 UTC
No problems for me with apr-1.3.9-3 under 2.6.24-24-xen. Thanks!

Comment 9 Joe Orton 2009-12-08 08:16:12 UTC
Great, thanks for reporting back.  Thanks also to Bojan for dealing with the issue!


Note You need to log in before you can comment on or make changes to this bug.