Bug 52596 - printconf-0.3.23-1 fails to make printcap
printconf-0.3.23-1 fails to make printcap
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: printconf (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 22:50 EDT by sean
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 22:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-08-25 22:50:04 EDT
Description of Problem:
I. I create a printer definition in printconf-gui ( or *.tui) and save
changes. Then try to print a test page. printconf tells me that lpd restart
has succeeded. Then it tells me that there was an error in printing the
test page.

2. In fact, the lpd restart fails. It fails because no printers are
defined:

[root@localhost init.d]# ./lpd status
lpd is stopped
[root@localhost init.d]# ./lpd start 
Starting lpd: No Printers Defined                          [  OK  ]
[root@localhost init.d]# ./lpd status
lpd is stopped


3. printconf-*ui continues to remember the printer definition, but
printconf-backend fails to write it to printcap. There's nothing in
printcap. lpd never starts.

FWIW:
[root@localhost init.d]# rpm -q alchemist
alchemist-1.0.16-1
[root@localhost init.d]# rpm -q foomatic 
foomatic-1.1-0.20010717.4



Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 sean 2001-08-27 18:30:17 EDT
Figured it out.

1. I have perl 5.6.1 installed. One of the rpm's (printconf, alchemits, foomatic
? ) installs the needed perl modules (e.g. Storable.pm) in
/usr/lib/perl5/site_perl/5.6.0/i386-linux, which is not in the @INC array. When
rpintconf_backend.py calls the perl script it fails, because it can't find the
modules..

2. I patched my printconf_backend.py, by doing:
   perl_pipe = os.open("perl  -I /usr/lib/perl5/site_perl/5.6.0/i386-linux",
"w");

 at the end of the Magicfilter Configuration. Now works for me.

3. You may not want to fix this for those who don't stay with the rh standard
issue, but you could consider addding a perl 5.6.0 dependency. Also, printconf
does give a lpd restart successful message, when it  isn't.

Note You need to log in before you can comment on or make changes to this bug.