Bug 526002 - Failed adding php-channel-phpunit due to date() error message
Summary: Failed adding php-channel-phpunit due to date() error message
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php-channel-phpunit
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-28 08:56 UTC by Renich Bon Ciric
Modified: 2010-09-04 14:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-04 14:09:16 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2009-09-28 08:56:09 UTC
Description of problem:
while installing it gives a horrible error message from date(); complaining about the usage of the system's timezone settings.

Version-Release number of selected component (if applicable):
php-channel-phpunit-1.0-4.fc12.noarch

How reproducible:
yum install php-channel-phpunit-1.0-4.fc12.noarch
  
Actual results:

[root@introdesk ~]# yum install php-channel-phpunit php-pear-Auth-SASL php-pear-DB php-pear-Image-GraphViz php-pear-Log php-pear-MDB2 php-pear-Mail php-pear-Net-SMTP php-pear-Net-Socket php-pear-PHPUnit
Loaded plugins: fastestmirror, merge-conf, post-transaction-actions, presto, refresh-packagekit, remove-with-leaves, show-leaves
Loading mirror speeds from cached hostfile
 * rawhide: chi-10g-1-mirror.fastsoft.net
 * rpmfusion-free-rawhide: mirrors.cat.pdx.edu
 * rpmfusion-nonfree-rawhide: mirrors.cat.pdx.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-channel-phpunit.noarch 0:1.0-4.fc12 set to be updated
---> Package php-pear-Auth-SASL.noarch 0:1.0.3-1.fc12 set to be updated
---> Package php-pear-DB.noarch 0:1.7.13-3.fc12 set to be updated
---> Package php-pear-Image-GraphViz.noarch 0:1.2.1-6.fc12 set to be updated
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz-1.2.1-6.fc12.noarch
---> Package php-pear-Log.noarch 0:1.11.5-1.fc12 set to be updated
---> Package php-pear-MDB2.noarch 0:2.4.1-4.fc12 set to be updated
---> Package php-pear-Mail.noarch 0:1.1.14-4.fc12 set to be updated
---> Package php-pear-Net-SMTP.noarch 0:1.3.3-2.fc12 set to be updated
---> Package php-pear-Net-Socket.noarch 0:1.0.9-3.fc12 set to be updated
---> Package php-pear-PHPUnit.noarch 0:3.3.17-1.fc12 set to be updated
--> Running transaction check
---> Package graphviz.x86_64 0:2.20.3-5.fc12.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================
 Package                                        Arch                          Version                                   Repository                      Size
=============================================================================================================================================================
Installing:
 php-channel-phpunit                            noarch                        1.0-4.fc12                                rawhide                        4.4 k
 php-pear-Auth-SASL                             noarch                        1.0.3-1.fc12                              rawhide                         11 k
 php-pear-DB                                    noarch                        1.7.13-3.fc12                             rawhide                         94 k
 php-pear-Image-GraphViz                        noarch                        1.2.1-6.fc12                              rawhide                         11 k
 php-pear-Log                                   noarch                        1.11.5-1.fc12                             rawhide                         50 k
 php-pear-MDB2                                  noarch                        2.4.1-4.fc12                              rawhide                        103 k
 php-pear-Mail                                  noarch                        1.1.14-4.fc12                             rawhide                         24 k
 php-pear-Net-SMTP                              noarch                        1.3.3-2.fc12                              rawhide                         17 k
 php-pear-Net-Socket                            noarch                        1.0.9-3.fc12                              rawhide                         11 k
 php-pear-PHPUnit                               noarch                        3.3.17-1.fc12                             rawhide                        270 k
Installing for dependencies:
 graphviz                                       x86_64                        2.20.3-5.fc12.1                           rawhide                        777 k

Transaction Summary
=============================================================================================================================================================
Install      11 Package(s)
Upgrade       0 Package(s)

Total download size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 1.3 M
(1/11): graphviz-2.20.3-5.fc12.1.x86_64.rpm                                                                                           | 777 kB     00:01     
(2/11): php-channel-phpunit-1.0-4.fc12.noarch.rpm                                                                                     | 4.4 kB     00:00     
(3/11): php-pear-Auth-SASL-1.0.3-1.fc12.noarch.rpm                                                                                    |  11 kB     00:00     
(4/11): php-pear-DB-1.7.13-3.fc12.noarch.rpm                                                                                          |  94 kB     00:00     
(5/11): php-pear-Image-GraphViz-1.2.1-6.fc12.noarch.rpm                                                                               |  11 kB     00:00     
(6/11): php-pear-Log-1.11.5-1.fc12.noarch.rpm                                                                                         |  50 kB     00:00     
(7/11): php-pear-MDB2-2.4.1-4.fc12.noarch.rpm                                                                                         | 103 kB     00:00     
(8/11): php-pear-Mail-1.1.14-4.fc12.noarch.rpm                                                                                        |  24 kB     00:00     
(9/11): php-pear-Net-SMTP-1.3.3-2.fc12.noarch.rpm                                                                                     |  17 kB     00:00     
(10/11): php-pear-Net-Socket-1.0.9-3.fc12.noarch.rpm                                                                                  |  11 kB     00:00     
(11/11): php-pear-PHPUnit-3.3.17-1.fc12.noarch.rpm                                                                                    | 270 kB     00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                        202 kB/s | 1.3 MB     00:06     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : graphviz-2.20.3-5.fc12.1.x86_64                                                                                                      1/11 
  Installing     : php-pear-Image-GraphViz-1.2.1-6.fc12.noarch                                                                                          2/11 
  Installing     : php-pear-MDB2-2.4.1-4.fc12.noarch                                                                                                    3/11 
  Installing     : php-pear-DB-1.7.13-3.fc12.noarch                                                                                                     4/11 
  Installing     : php-channel-phpunit-1.0-4.fc12.noarch                                                                                                5/11 
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /usr/share/pear/PEAR/Registry.php on line 1012
PHP Stack trace:
PHP   1. {main}() /usr/share/pear/pearcmd.php:0
PHP   2. PEAR_Command_Common->run() /usr/share/pear/pearcmd.php:305
PHP   3. PEAR_Command_Channels->doAdd() /usr/share/pear/PEAR/Command/Common.php:271
PHP   4. PEAR_Registry->addChannel() /usr/share/pear/PEAR/Command/Channels.php:492
PHP   5. PEAR_Registry->_addChannel() /usr/share/pear/PEAR/Registry.php:1849
PHP   6. date() /usr/share/pear/PEAR/Registry.php:1012
  Installing     : php-pear-Auth-SASL-1.0.3-1.fc12.noarch                                                                                               6/11 
  Installing     : php-pear-Net-Socket-1.0.9-3.fc12.noarch                                                                                              7/11 
  Installing     : php-pear-Net-SMTP-1.3.3-2.fc12.noarch                                                                                                8/11 
  Installing     : php-pear-Mail-1.1.14-4.fc12.noarch                                                                                                   9/11 
  Installing     : php-pear-Log-1.11.5-1.fc12.noarch                                                                                                   10/11 
  Installing     : php-pear-PHPUnit-3.3.17-1.fc12.noarch                                                                                               11/11 

Installed:
  php-channel-phpunit.noarch 0:1.0-4.fc12                php-pear-Auth-SASL.noarch 0:1.0.3-1.fc12          php-pear-DB.noarch 0:1.7.13-3.fc12                
  php-pear-Image-GraphViz.noarch 0:1.2.1-6.fc12          php-pear-Log.noarch 0:1.11.5-1.fc12               php-pear-MDB2.noarch 0:2.4.1-4.fc12               
  php-pear-Mail.noarch 0:1.1.14-4.fc12                   php-pear-Net-SMTP.noarch 0:1.3.3-2.fc12           php-pear-Net-Socket.noarch 0:1.0.9-3.fc12         
  php-pear-PHPUnit.noarch 0:3.3.17-1.fc12               

Dependency Installed:
  graphviz.x86_64 0:2.20.3-5.fc12.1                                                                                                                          

Complete!
New leaves:
  php-pear-PHPUnit.noarch
You have new mail in /var/spool/mail/root




Expected results:
normal installation message

Comment 1 Bug Zapper 2009-11-16 13:01:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Fedora Admin XMLRPC Client 2010-08-11 17:48:05 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Remi Collet 2010-09-04 14:09:16 UTC
This is not a bug.

No error, only a "warning" which can be easily fixed by setting date.timezone (in /etc/php-cli.ini p.e.)


Note You need to log in before you can comment on or make changes to this bug.