Bug 526023 - Unable to connect to PPPOE DSL connections using NetworkManager
Summary: Unable to connect to PPPOE DSL connections using NetworkManager
Keywords:
Status: CLOSED DUPLICATE of bug 453880
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 11
Hardware: i586
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-28 11:53 UTC by Enygma
Modified: 2009-10-04 22:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-04 22:09:48 UTC


Attachments (Terms of Use)

Description Enygma 2009-09-28 11:53:38 UTC
Description of problem:
After upgrading from Fedora 10 to Fedora 11, PPPOE stopped working with NetworkManager.
It works ok if I use system-config-network or pppoe-setup from the command line but NetworkManager just fails to connect, immediately disconnecting me after inputing the user/password for the DSL connection.
The message I get in the taskbar pop-up is "Network Disconnected" without any other information.
The password is correct. The ISP is ok (tested on XP).
I have installed rp-pppoe and ppp packages and the DSL tab is present in the NetworkManager connection settings window with all my settings from previous Fedora 10 setup.
Note: I'm not sure if they are related, but the password for the DSL connection will not get saved, but maybe it's ok since I get prompted a dialog where I can enter the user/pass and service.

Version-Release number of selected component (if applicable):
NetworkManager Applet 0.7.1
NetworkManager.i586    1:0.7.1-8.git20090708.fc11               
rp-pppoe.i586          3.10-2.fc11 
ppp.i586               2.4.4-11.fc11

How reproducible:
Every time I try to conenct to my PPPOE connection.

Steps to Reproduce:
1. Upgrade from Fedora 10 to Fedora 11 using preupgrade.
2. Try to connect to your previously configured (or even a newly configured) PPPOE (DSL) connection.
3. 
  
Actual results:
I get a "Network disconnected." message right after a connection attempt.
First the green light on the nm-applet "connecting icon" appears, after 2-3 seconds the second one occasionally appears as well but right after that, I get a disconnected.

Expected results:
Successful connection.

Additional info:

Comment 1 Enygma 2009-09-29 21:42:17 UTC
I could really use some help with this one.

I am unable to use the Internet on my Fedora. system-network-config and/or pppoe-setup don't seem to do the trick anymore. Don`t know exactly why.

Please help.

Thank you!

Comment 2 Enygma 2009-10-04 22:09:48 UTC
Fixed by using workaround.

Deleted ~/.gnome2/keyrings

gnome-keyring was the culprit. ( gnome-keyring-ask: Gtk: cannot open display: | gnome-keyring-daemon[10212]: couldn't write data to ask tool: Broken pipe )

Most likely duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=453880

*** This bug has been marked as a duplicate of bug 453880 ***


Note You need to log in before you can comment on or make changes to this bug.