Bug 52604 - /etc/init.d/ipchains loads ipchains module
Summary: /etc/init.d/ipchains loads ipchains module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ipchains   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-26 13:47 UTC by Gene Czarcinski
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 18:47:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2001-08-26 13:47:06 UTC
Description of Problem:


Version-Release number of selected component (if applicable):
By default, /etc/init.d/ipchains loads the ipchains module even if
/etc/sysconfig/ipchains does not exist (the user specified no firewall
during the install).

Since both /etc/init.d/ipchains and /etc/init.d/iptables are both run
during bootup by default and iptables will exit if the ipchains module has
been loaded, we need to add a test for existance of /etc/sysconfig/ipchains
and if it does not exist, exit before loading the module.

How Reproducible:
every time

Steps to Reproduce:
1. Install and run rc1
2. create an iptables configuration but it will not run
3. 

Actual Results:
by default, ipchains module is loaded

Expected Results:
ipchains is loaded only if /etc/sysconfig/ipchains exists

Additional Information:
	Of course there is the case when both /etc/sysconfig/ipchains AND
/etc/sysconfig/iptables both exist but ??

Comment 1 Bill Nottingham 2001-08-27 01:53:43 UTC
The ipchains initscripts is part of the ipchains package, assigning there.

Comment 2 Mike A. Harris 2001-09-02 07:40:44 UTC
Fixed in ipchains release 1.3.10-10

Comment 3 Gene Czarcinski 2003-10-27 18:47:54 UTC
OBE now I am sure

Comment 4 Mike A. Harris 2003-10-27 19:15:10 UTC
Out of Body Experience?


Note You need to log in before you can comment on or make changes to this bug.