Bug 526066 - Cypress CY7C68300A USB to ATA converter does not boot on kernels greater than 2.6.29.4-167
Summary: Cypress CY7C68300A USB to ATA converter does not boot on kernels greater than...
Keywords:
Status: CLOSED DUPLICATE of bug 524998
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-28 16:14 UTC by Nic Stevens
Modified: 2009-09-29 23:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 23:53:53 UTC


Attachments (Terms of Use)

Description Nic Stevens 2009-09-28 16:14:38 UTC
Cypress CY7C68300A USB to ATA converter does not boot on kernels greater than 
2.6.29.4-167

Version-Release number of selected component (if applicable): 2.6.30.5-43.fc11.i686.PAE


How reproducible: Consistentnly


Steps to Reproduce:
1. Connect CY7C68300A USB to ATA converter
2. Install Fedora 11 x86-64
3. Boot system
  
Actual results:
scsi 3:0:0:0: Direct-Access     ST320082 0A               0000 PQ: 0 ANSI: 0
sd 3:0:0:0: [sdb] 390721968 512-byte hardware sectors: (200 GB/186 GiB)
sd 3:0:0:0: [sdb] Write Protect is off
sd 3:0:0:0: [sdb] Mode Sense: 27 00 00 00
sd 3:0:0:0: [sdb] Assuming drive cache: write through
sd 3:0:0:0: [sdb] 390721968 512-byte hardware sectors: (200 GB/186 GiB)
sd 3:0:0:0: [sdb] Write Protect is off
sd 3:0:0:0: [sdb] Mode Sense: 27 00 00 00
sd 3:0:0:0: [sdb] Assuming drive cache: write through
sd 3:0:0:0: [sdb] Assuming drive cache: write through
(system stops booting here)

Expected results:
...
sd 3:0:0:0: [sdb] 390721968 512-byte hardware sectors: (200 GB/186 GiB)
sd 3:0:0:0: [sdb] Write Protect is off
sd 3:0:0:0: [sdb] Mode Sense: 27 00 00 00
sd 3:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1 sdb2 sdb3
sd 3:0:0:0: [sdb] Attached SCSI disk
sd 3:0:0:0: Attached scsi generic sg2 type 0
(system continues booting here)


Additional info:
I installed F11 i386 from DVD and the install worked perfectly. When I booted to a desktop I was prompted to install updates which I did. After updates were installed the system would hang in the same manner as the x86-64 version did (see above)

The working kernel that was installed was: 2.6.29.4-167.fc11.i686.PAE
The kernel that was updated and does not work is: 2.6.30.5-43.fc11.i686.PAE

Comment 1 Nic Stevens 2009-09-29 02:43:37 UTC
I created a boot partition on my internal SATA Seagate leaving just the root fs on the external Cypress drive. I installed F11 x86_64 and was able to boot the system. Ran updates and was updated to 2.6.30.5-43.fc11.x86_64 and now the system hangs on boot at the same place.

While the system is in this state I can turn off and on the drive and get console messages that the drive is detached and reattached but the boot process never goes further.

Comment 2 Chuck Ebbert 2009-09-29 23:53:53 UTC

*** This bug has been marked as a duplicate of bug 524998 ***


Note You need to log in before you can comment on or make changes to this bug.