Bug 52608 - tcltk-8.3.3-64 itclsh build failure
Summary: tcltk-8.3.3-64 itclsh build failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-26 15:57 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 15:57:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-26 15:57:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
tcltk build (rpm -ba tcltk.spec) fails to build itclsh due to bad
itcl-3.2-makecfg.patch.

The itclsh link phase contains element "-L@TCL_BUILD_STUB_LIB_SPEC@",
which expands to "-L-L/..."; i.e. the @TCL_BUILD_STUB_LIB_SPEC@
already contains the -L. Removing the superfluous -L from the patch
fixes the problem.

Version-Release number of selected component (if applicable):
8.3.3-64

How reproducible:
Always

Steps to Reproduce:
1. "rpm -ba tcltk.spec" and keep an eye on the output.

Actual Results:  Build and packaging completes [BAD!], but the package 
doesn't
contain the intended itclsh binary.

Expected Results:  Succesful build -- or at least termination of the build 
at
the error position.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.