Bug 526111 - virt-manager add storage volume allows an empty name field
virt-manager add storage volume allows an empty name field
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-09-28 15:48 EDT by Darryl L. Pierce
Modified: 2015-06-21 20:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 14:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darryl L. Pierce 2009-09-28 15:48:39 EDT
Description of problem:
If I select to create a volume without entering a filename, it creates one named ".ing"

Version-Release number of selected component (if applicable):
(mcpierce@mcpierce-laptop:Documents)$ rpm -q virt-manager
virt-manager-0.8.0-3.fc11.noarch


How reproducible:
100%

Steps to Reproduce:
1. Open virt-manager.
2. View storage pools.
3. Add a new storage volume.
4. Click "Create Volume" without entering a name.
  
Actual results:
A file named /var/lib/libvirt/images/.ing is created.

Expected results:
An error message saying to enter a name first.

Additional info:
Comment 1 Mark McLoughlin 2009-10-02 10:31:24 EDT
Confirmed

(moving to rawhide since this version isn't in F-11)
Comment 2 Mark McLoughlin 2009-10-02 10:32:35 EDT
Oh, one thought - the create volume button should probably be insensitive until a name is entered
Comment 3 Cole Robinson 2009-10-05 14:53:16 EDT
This is fixed in virt-manager-0.8.0-7.fc12 which is queued up for F12 GA. Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.