Bug 526136 - volume jumps up when kde startup .
Summary: volume jumps up when kde startup .
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 01:56 UTC by Sergio Monteiro Basto
Modified: 2009-09-29 14:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 14:04:48 UTC


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2009-09-29 01:56:55 UTC
Description of problem:

When kde startup the session sound is mute , but after pulseaudio set sound at last time was , before reboot.
My kde session have one default for sound , which is modify by pulseaudio , after session starts, and when session starts.
I can visualize on kmix, session starts and kmix is mute , after a while kmix is modified with "the last time what ever was the sound volume before reboot".
So somestimes I have big entry sounds when I begging one session because last time before reboot I had use phones (at train). 

Version-Release number of selected component (if applicable):
f11 updated

How reproducible:
always

 
Actual results:
volume jumps on init kde session.

Expected results:
volume should remain mute at begin of the session, as default I had set, I could set other behavior like is now , but I don't.

Additional info:
I'd like uninstall pulseaudio ...
this is a bug :).

Comment 1 Lennart Poettering 2009-09-29 03:50:43 UTC
Reassigning to KDE.

I think kmix still goes directly to the low-level alsa mixer and will hence show all the internal volume changes PA does. It should use the proper PA mixer interface instead.

Comment 2 Kevin Kofler 2009-09-29 14:04:48 UTC
Uhm, pick your choice of DEFERRED, WONTFIX, CANTFIX or NOTABUG...

1. We can't ship code which is not there. The PulseAudio support in KMix is not anywhere near usable, almost everything is commented out. Even if one of us would start working on it now, it'd take time to implement it. For now, ALSA mixing is what we have. It's either that, or a fake, non-working PA backend or no KMix at all. We chose the option which is actually useful.
2. It is part of KDE's philosophy to show all the detailed options, in this case volume sliders. I think we'll still want to offer the full ALSA mixer even once we do get PA integration.
3. If you are bothered by PA continuously mucking with your ALSA volumes, you can disable the "flat volumes" feature in PulseAudio. (I think this feature is broken by design and should be disabled by default, but that's just me...) Just:
echo "flat-volumes = no" >>~/.pulse/daemon.conf
or as root:
echo "flat-volumes = no" >>/etc/pulse/daemon.conf
for a systemwide change. With "flat volumes" enabled, as Lennart is saying, it is not a bug that PA is playing around with your volumes, it's how that feature is designed.

Comment 3 Kevin Kofler 2009-09-29 14:05:46 UTC
Actually it's not just me who thinks flat volumes suck, the maintainers of Ubuntu's pulseaudio package think the same:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/403859
;-)


Note You need to log in before you can comment on or make changes to this bug.