Bug 526147 - "xtermc" / "xtermm" terminfo definitions are missing smul/rmul
Summary: "xtermc" / "xtermm" terminfo definitions are missing smul/rmul
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ncurses
Version: 5.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: BaseOS QE
URL: http://bugs.opensolaris.org/bugdataba...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 05:05 UTC by Pat Kartas
Modified: 2010-04-13 16:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-13 16:06:02 UTC


Attachments (Terms of Use)

Description Pat Kartas 2009-09-29 05:05:16 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

The "xterm" terminfo definition includes smul/rmul to start/end underline text.  The AT&T-derived "xtermm" and "xtermc" entries are missing this, so underlined text will not be displayed when using "xtermc" (reading a manual page is one obvious example of this).

Reproducible: Always

Steps to Reproduce:
1. TERM=xterm man ls
2. TERM=xtermc man ls

Actual Results:  
The text in the second "man" command is reversed instead of underlined.


Expected Results:  
Both "man" commands should produce the same result.

Comment 1 Thomas E. Dickey 2009-09-29 21:08:40 UTC
See the comment in terminfo.src:

http://invisible-island.net/datafiles/current/terminfo.src.gz

# These (xtermc and xtermm) are distributed with Solaris.  They refer to a
# variant of xterm which is apparently no longer supported, but are interesting
# because they illustrate SVr4 curses mouse controls - T.Dickey

There's no reason to use those entries unless you happen to have a running
copy of the variant cited.  If you do, it would be interesting to spend
some time validating the entry.  Otherwise, there's no reason to change the
entries.

Comment 2 Pat Kartas 2009-09-30 02:11:07 UTC
I've an environment with mixed Solaris and RH, and while RH's $TERM, if set to xterm, supports colour (I like to set terminal colours when su-ing, to warn myself), Solaris' doesn't, and so I use xtermc instead, which works on both, except with the underline bug. I set $TERM in PuTTY and was hoping to not have to set different settings for RH and Solaris, but meh it's a tiny bug and especially if it's not supported any more, I'm sure I'll deal with it.

Comment 3 Thomas E. Dickey 2009-09-30 08:30:14 UTC
On Solaris, you can install ncurses or (lacking root access)
it's possible to install in your home directory a small
terminal database.  ncurses has a correct definition for
putty as well as for xterm, so you should be able to make
it work.

Comment 4 Pat Kartas 2009-10-02 03:47:56 UTC
Hmmmm - there are quite a lot of machines involved (potentially hundreds) and home directories unfortunately aren't common on all of them. I think I'll just set $TERM to xtermc each time on Solaris and have Linux "just work" with xterm.

Comment 5 Thomas E. Dickey 2009-10-02 08:48:02 UTC
It's not a matter of directories: the tic program compiles
a source for the terminal entry.  On Solaris, that would
use one file for the entry, and a couple of directory-levels
as part of the structure for the terminal database.

Comment 6 Miroslav Lichvar 2010-04-13 16:06:02 UTC
Unless Thomas wants to change this upstream, I'm closing this as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.