Bug 526154 - localisation breaks sending mail
Summary: localisation breaks sending mail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 13
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Target
TreeView+ depends on / blocked
 
Reported: 2009-09-29 06:21 UTC by Milos Jakubicek
Modified: 2018-04-11 09:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-21 13:37:27 UTC
Type: ---


Attachments (Terms of Use)
SMTP log with reproduction (2.54 KB, text/plain)
2009-09-30 14:12 UTC, Matěj Cepl
no flags Details


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 523658 None None None Never

Description Milos Jakubicek 2009-09-29 06:21:00 UTC
Description of problem:

After update from beta3 to beta4 I noticed that I'm unable to send any mails. Trying to do so resulted into an error message that TB couldn't get password (message was in Czech). As I know there have been changes in handling passwords, I deleted all passwords and the related files from TB dir and tried again, with no result. TB was able to do IMAP/POP, but no SMTP. I also tried removing the SMTP servers and adding them again. Finally, when I wanted to get the unlocalised error message, it started to work, TB asked for SMTP password and sent my mails successfully. 

I can reproduce the problem again, setting locale to "cs_CZ.UTF-8" breaks sending any mail, switching to "en_US.UTF-8" makes it possible again.

Version-Release number of selected component (if applicable):

thunderbird-3.0-2.7.b4.fc11.x86_64

Comment 1 Martin Stransky 2009-09-29 11:24:53 UTC
Hm, unable to reproduce within cs_CZ.UTF-8 locale (thunderbird-3.0-3.9.b4.fc12.i686). 

Do you use any diacritic in your password?

Comment 2 Jan Bušta 2009-09-29 11:27:43 UTC
No, the password is without diacritic.

Comment 3 Martin Stransky 2009-09-29 12:39:39 UTC
Which security check you you use on your SMTP server? Looks like there are some problems with localization & secured SMTP servers...

Comment 4 Milos Jakubicek 2009-09-29 17:39:07 UTC
It's an authenticated SMTP over SSL/TLS.

Comment 5 Matěj Cepl 2009-09-30 14:12:55 UTC
Created attachment 363193 [details]
SMTP log with reproduction

Yes it seems to be broken. For debugging to get a log take a look at https://wiki.mozilla.org/MailNews:Logging#Linux.2Funix for information how to do it.

Comment 6 Milos Jakubicek 2009-10-15 08:02:06 UTC
Marking as F12 blocker since this could affect quite a lot of people (anybody with locale not set to en_US, probably).

Comment 7 Milos Jakubicek 2009-10-21 17:56:17 UTC
Some more info:

- it seems that it affects only Czech localisation:), tried de_DE, sk_SK, zh_TW and nn_NO, all of them worked.

- copying Slovak localisation over the Czech one doesn't help.

- I filed this upstream too.

Comment 8 Milos Jakubicek 2009-10-21 18:51:30 UTC
From the upstream feedback (see the referenced bugreport) it should be fixed in the RC which hopefully will make it into F12.

Comment 9 Milos Jakubicek 2009-10-21 19:24:56 UTC
(In reply to comment #7)
> 
> - copying Slovak localisation over the Czech one doesn't help.
>

I didn't notice there are files with language dependent names in the relevant directories, therefore it didn't work, otherwise the fix lies just in changing:

smtpEnterPasswordPromptWithUsername=Zadejte heslo k účtu %S na %1$S:

to

smtpEnterPasswordPromptWithUsername=Zadejte heslo k účtu %2$S na %1$S:

in the locale/cs/messenger/messengercompose/composeMsgs.properties file which is in /usr/lib64/thunderbird-3.0b4/extensions/langpack-cs@thunderbird.mozilla.org/chrome/cs.jar

That's it.

Comment 10 Adam Williamson 2009-10-23 17:37:29 UTC
This was discussed at the blocker meeting. As Milos' initial thought that this would affect all non-en locales turned out to be incorrect, we don't think this constitutes a release blocker; dropping to F12Target.

However, releng will certainly accept a tag request to have a fixed build put in F12 final, and it would be nice to see that. Martin, seems like Milos has identified the fix pretty exactly: can you fix this and send a build to Koji for testing and tagging? thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Matěj Cepl 2009-10-24 19:59:50 UTC
Of course, s/Martin/Jan/ :)

Comment 12 Milos Jakubicek 2009-11-09 00:27:40 UTC
*ping*

Do not forget to fix this, please! If you don't have time let me know and I'll do that. I do not want to have a Thunderbird which cannot send mails in Czech localisation in F12 (because of such a dummy mistake)!

Comment 13 Fedora Update System 2009-11-10 14:35:00 UTC
sunbird-1.0-0.13.20090916hg.fc12,thunderbird-3.0-3.10.b4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sunbird-1.0-0.13.20090916hg.fc12,thunderbird-3.0-3.10.b4.fc12

Comment 14 Fedora Update System 2009-11-11 14:57:22 UTC
sunbird-1.0-0.13.20090916hg.fc12, thunderbird-3.0-3.10.b4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sunbird thunderbird'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11329

Comment 15 Bug Zapper 2010-03-15 12:54:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 16 Fedora Update System 2010-07-21 12:50:28 UTC
thunderbird-3.0.6-1.fc12,sunbird-1.0-0.23.20090916hg.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/thunderbird-3.0.6-1.fc12,sunbird-1.0-0.23.20090916hg.fc12


Note You need to log in before you can comment on or make changes to this bug.