This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526199 - cannot set ownership on /pub/fedora/linux/development/i386/os/images/boot.iso: Read-only file system
cannot set ownership on /pub/fedora/linux/development/i386/os/images/boot.iso...
Status: CLOSED DUPLICATE of bug 517304
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 04:49 EDT by Jens Petersen
Modified: 2009-10-02 11:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 11:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-09-29 04:49:26 EDT
Description of problem:
When I try to do a local file install v-m claims

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-5.fc12

How reproducible:
every time

Steps to Reproduce:
1. try to install guest from local iso mounted by nfs.
  
Actual results:
Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: libvir: QEMU error : cannot set ownership on /pub/fedora/linux/development/i386/os/images/boot.iso: Read-only file system

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1575, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: libvir: QEMU error : cannot set ownership on /pub/fedora/linux/development/i386/os/images/boot.iso: Read-only file system

'

Expected results:
no backtrace
Comment 1 Mark McLoughlin 2009-10-02 11:33:34 EDT
Thanks Jens; pretty sure this is covered by #517304

*** This bug has been marked as a duplicate of bug 517304 ***

Note You need to log in before you can comment on or make changes to this bug.