Bug 526205 - Unable to find XIM with the certain locale
Unable to find XIM with the certain locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 05:31 EDT by Akira TAGOH
Modified: 2011-01-05 06:20 EST (History)
3 users (show)

See Also:
Fixed In Version: imsettings-1.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 06:20:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example for xinput file (106 bytes, text/plain)
2009-09-29 05:31 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2009-09-29 05:31:12 EDT
Created attachment 362977 [details]
example for xinput file

Description of problem:
bringing up XIM with the different locale to the system locale ends up to raise an error like, "No such input method on your system: blahblahblah". but it appears in the list.

Version-Release number of selected component (if applicable):
imsettings-0.107.4-1.fc12.

How reproducible:
always

Steps to Reproduce:
1.put attached into /etc/X11/xinit/xinput.d/
2.ln -s xcompose /etc/X11/xinit/xinput.d/pt_BR
3.LANG=pt_BR.UTF-8 imsettings-start "X locale compose"
  
Actual results:
it raises an error.

Expected results:
IM should start.

Additional info:
LANG=pt_BR.UTF-8 imsettings-list shows that as available.
Comment 1 Jens Petersen 2009-12-02 19:23:22 EST
Dunno if we still need this with the support for XIM @im=none
added to none.conf?
Comment 2 Akira TAGOH 2009-12-03 01:06:26 EST
you mean GTK_IM_MODULE=xim.

Well, I don't still think it's the right solution widely, without XIM support in imsettings at least, because it effects all of the users and switching from/to something to/from it requires restarting the desktop. plus, the worst thing may be for CIJK users who tentatively wants to disable IM say. in this case, it works on GTK+ applications but the native X applications and Qt applications etc still connects to IM through XIM, because XMODIFIERS still points to IM's.

Since we missed the way of fixing that issue in the gtk immodule, we should try to find out the better way for everyone.
Comment 3 Bug Zapper 2010-03-15 08:54:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Akira TAGOH 2011-01-05 06:20:15 EST
This should be fixed in imsettings-1.0.0-1.fc15.

Note You need to log in before you can comment on or make changes to this bug.