Bug 52621 - rpm upgrade mode seems broken
rpm upgrade mode seems broken
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 06:30 EDT by Gerald Teschl
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-27 12:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-08-27 06:30:34 EDT
rpm-4.0.3-0.93

I just manually upgraded to the kde packages from rawhide and
after that kdm refused to start. So I did some investigations and
found out that numerous files in kdebase were missing/modified in
kdebase. So I checked to the other packages some of them were fine
others had also missing files.

As an easy testcase: Upgrade kdenetwork-ppp and the file /etc/pam.d/kppp
will be gone.

I had similar problems with upgrading foomatic,an where an entire
directory tree was gone after upgrading the rpm, so I think this
is an rpm and not a packing bug.
Comment 1 Jeff Johnson 2001-08-27 08:20:16 EDT
I downgraded kdenetwork-ppp to 2.2-4 and then upgraded to 2.2-5 w/o
problem using rpm-4.0.3-0.97.

Yes, foomatic has many files missing, dunno why, off to foomatic
Comment 2 Jeff Johnson 2001-08-27 12:05:18 EDT
Hmmm, back to rpm. Turns out kdebase is trying to replace
a directory with a symlink which terminates payload
unpacking immediately on an EISDIR return from rename(2).

Ick, no error message from rpm. Will be repaired in
rpm-4.0.3-0.98.

foomatic has other problems, will be rebuilt.

Off to kdebase to fix the packaging problem.with the
symlink. Bero, here's the missing rpm error message

D: fini      120777  1 (   0,   0)        20 /usr/share/config/kdm;3b8a6eaf save
GZDIO:    3447 reads, 28237824 total bytes in 6.018 secs
error: unpacking of archive failed on file /usr/share/config/kdm: cpio: rename
failed - Is a directory
Comment 3 Bernhard Rosenkraenzer 2001-08-27 12:44:44 EDT
We don't support updating from beta or rawhide packages.
rpm -q --changelog kdelibs for details. It clearly states you're not supposed 
to update it from earlier 2.2-* versions.

Note You need to log in before you can comment on or make changes to this bug.