Bug 526223 - --label kickstart option not written in anaconda-ks.cfg
Summary: --label kickstart option not written in anaconda-ks.cfg
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 11:05 UTC by Alexander Todorov
Modified: 2009-10-05 20:43 UTC (History)
3 users (show)

Fixed In Version: anaconda-13.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-05 12:46:51 UTC
Type: ---


Attachments (Terms of Use)

Description Alexander Todorov 2009-09-29 11:05:01 UTC
Description of problem:
When using a kickstart partitioning command which has --label option this option is not present in the resulting anaconda-ks.cfg file.

Version-Release number of selected component (if applicable):
anaconda-12.31-1.fc12.x86_64.rpm
pykickstart-1.63-1.fc12.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Install with ks.cfg that has:
part /multi-stage --fstype="ext3" --size=100 --label=MULTISTAGE
2.
3.
  
Actual results:
The resulting anaconda-ks.cfg has:
#part /multi-stage --fstype=ext3 --size=100


Expected results:
#part /multi-stage --fstype=ext3 --size=100 --label=MULTISTAGE


Additional info:

Comment 2 Chris Lumens 2009-10-02 18:14:05 UTC
Sadly, all the anaconda-ks.cfg writing is still done by anaconda.  This is because none of the __str__ methods in storage/ know to write out a --label=.


Note You need to log in before you can comment on or make changes to this bug.