Bug 526241 - Add SUN CSM100_R_FC to supported RDAC devices.
Summary: Add SUN CSM100_R_FC to supported RDAC devices.
Keywords:
Status: CLOSED DUPLICATE of bug 524335
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Rob Evers
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 12:53 UTC by Wade Mealing
Modified: 2009-10-01 15:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-01 15:35:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
enable support for the aforementioned sun device. (414 bytes, patch)
2009-09-29 12:58 UTC, Wade Mealing
no flags Details | Diff

Description Wade Mealing 2009-09-29 12:53:56 UTC
Description of problem:

The sun CSM100_R_FC device is not listed as a supported rdac device.  It is currently listed upstream.

Version-Release number of selected component (if applicable):

Fix attempted on 2.6.18-166

How reproducible:

Every time.

Steps to Reproduce:
1. Configure multipath to use new dh_rdac
2. Wait
3. Fail device
  
Actual results:

d 7:0:0:100: rdac Dettached
sd 8:0:0:100: rdac Dettached
device-mapper: multipath: Cannot failover device because scsi_dh_rdac was not loaded.
device-mapper: multipath: Failing path 8:32.
device-mapper: multipath: Cannot failover device because scsi_dh_rdac was not loaded.
device-mapper: multipath: Failing path 8:48.
device-mapper: multipath: Cannot failover device because scsi_dh_rdac was not loaded.
device-mapper: multipath: Failing path 8:32.
device-mapper: multipath: Cannot failover device because scsi_dh_rdac was not loaded.
device-mapper: multipath: Failing path 8:48.
device-mapper: multipath: Cannot failover device because scsi_dh_rdac was not loaded.
device-mapper: multipath: Failing path 8:32.
Buffer I/O error on device dm-10, logical block 1545
lost page write due to I/O error on dm-10
Aborting journal on device dm-10.
Buffer I/O error on device dm-10, logical block 1545
lost page write due to I/O error on dm-10


Expected results:

Sep 29 13:46:56 cerberus kernel: device-mapper: multipath: Using scsi_dh module scsi_dh_rdac for failover/failback and device management.
Sep 29 13:46:56 cerberus multipathd: sanvol: load table [0 103473152 multipath 1 queue_if_no_path 1 rdac 2 1 round-robin 0 1 1 8:32 10000 round-robin 0 1 1 8:48 100
Sep 29 13:46:56 cerberus multipathd: dm-9: add map (uevent)
Sep 29 13:46:56 cerberus multipathd: dm-9: devmap already registered
Sep 29 13:47:06 cerberus multipathd: 8:32: reinstated
Sep 29 13:47:06 cerberus multipathd: 8:48: reinstated
Sep 29 13:48:27 cerberus kernel: sd 7:0:0:100: rdac: AVT mode detected
Sep 29 13:48:41 cerberus multipathd: 8:32: reinstated
Sep 29 13:48:41 cerberus multipathd: 8:48: reinstated
Sep 29 13:50:55 cerberus multipathd: dm-10: add map (uevent)

Additional information:

There are other SANS that are mentioned in the upstream configuration that should work, although these have not been backported as I have not had customer verification on if it works.

Comment 1 Wade Mealing 2009-09-29 12:58:47 UTC
Created attachment 363002 [details]
enable support for the aforementioned sun device.

Comment 4 Rob Evers 2009-10-01 15:35:13 UTC

*** This bug has been marked as a duplicate of bug 524335 ***


Note You need to log in before you can comment on or make changes to this bug.