Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 526281 - [PHX/ PHX2] NPE on Ticket.getExpirationInMillis() when expiration is null
Summary: [PHX/ PHX2] NPE on Ticket.getExpirationInMillis() when expiration is null
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Gatekeeper
Version: MR18
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Nathan Lugert
QA Contact:
URL:
Whiteboard:
Depends On: 537208
Blocks: 539723 540532
TreeView+ depends on / blocked
 
Reported: 2009-09-29 16:19 UTC by Nathan Lugert
Modified: 2010-11-18 16:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-18 16:58:24 UTC
Type: ---


Attachments (Terms of Use)

Description Nathan Lugert 2009-09-29 16:19:20 UTC
Description of problem:
Null Pointer Exception in Production Logs
2009-09-29 03:30:57,811 ERROR [STDERR] java.lang.NullPointerException
2009-09-29 03:30:57,811 ERROR [STDERR] 	at com.jboss.jbossnetwork.issuetracker.Tickets.getExpirationInMillis(Tickets.java:498)

I believe this is being caused by Gatekeeper trying to send a notification for a ticket that has no expiration time set. In this case the notification is not being sent. Need to add a null check.

Comment 1 Nicole Yancey 2009-10-15 13:20:14 UTC
Must go through Governance Board.

Comment 2 Nathan Lugert 2009-11-30 16:10:41 UTC
Added a Null check in Tickets.getExpirationInMillis and return null if is null, otherwise calculate and return the time in milliseconds.return null has no affect on the calling code, but the NullPointerException was causing product group notifications to not be sent if expiration was not previously set.

Comment 3 Nathan Lugert 2009-12-11 15:12:38 UTC
Testing not required for this bug. Moving to Release Pending

Comment 5 Nathan Lugert 2010-11-18 16:58:24 UTC
CSP no longer does ticketing. This can/should be closed.


Note You need to log in before you can comment on or make changes to this bug.