Bug 526288 - xmlto pdf USE_BACKEND should be configurable
Summary: xmlto pdf USE_BACKEND should be configurable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlto
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 16:39 UTC by Frank Ch. Eigler
Modified: 2009-09-29 18:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 17:47:37 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2009-09-29 16:39:41 UTC
While working on bug #526273, I found that the USE_BACKEND
variable from xmlto to the backend is hard-coded at "DEFAULT"
and there is no facility to change it.

If it were changeable, then bug #526273 could be mooted to
some extent by setting USE_BACKEND=DBLATEX, which does appear
to process that .xml file with a satisfying rc=0 exit grin.

Comment 1 Ondrej Vasik 2009-09-29 17:47:37 UTC
Sorry, but that's not a bug. You should not modify that parameter this way, it is just for internal use within the xmlto script. When you specify --with-dblatex parameter to xmlto, USE_BACKEND is set automatically to DBLATEX ... This USE_BACKEND=DEFAULT is filled at configure time due to request from debian, as they use dblatex or fop as default backend instead of passivetex. So closing NOTABUG ... Please read documentation (intentionally there is NO information about USE_BACKEND, as you should not modify it).

Additionally - #526273 seems to be passivetex issue - xmlto is just simple shell script and all processing is done by it's backends. I'll check what could be done with this, but many such issues simply could not be fixed easily (as passivetex is hard-to-maintain package with dead upstream).

Comment 2 Frank Ch. Eigler 2009-09-29 18:17:51 UTC
You're right, I didn't see the --with-dblatex option.


Note You need to log in before you can comment on or make changes to this bug.