Bug 526307 - Build python-pygments for EL4
Summary: Build python-pygments for EL4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pygments
Version: el4
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Milner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 246312
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 18:24 UTC by Nils Breunese
Modified: 2009-10-23 23:19 UTC (History)
1 user (show)

Fixed In Version: 1.1.1-1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-23 23:19:52 UTC
Type: ---


Attachments (Terms of Use)

Description Nils Breunese 2009-09-29 18:24:41 UTC
EPEL has a python-pygments package for EL5, but not EL4. Could this be added?

According to http://pygments.org/docs/installation/ "Pygments requires at least Python 2.3 to work correctly. Just to clarify: there won't ever be support for Python versions below 2.3. However, there are no other dependencies."

Comment 1 Steve Milner 2009-09-29 19:10:25 UTC
I will request EL-4. It looks to build fine in koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1717390

Comment 2 Steve Milner 2009-09-29 19:15:48 UTC
Requested EL-4 branch: https://bugzilla.redhat.com/show_bug.cgi?id=331081

Comment 3 Steve Milner 2009-09-29 19:24:37 UTC
/me facepalms .... wrong package :-) I'm checking on pygments shortly.

Comment 4 Steve Milner 2009-09-29 19:37:21 UTC
0.9 worked http://koji.fedoraproject.org/koji/taskinfo?taskID=1717499

I will update EL-5 and EL-4 together.

https://bugzilla.redhat.com/show_bug.cgi?id=246312

Comment 5 Steve Milner 2009-10-01 13:51:50 UTC
Update for EPEL4: https://admin.fedoraproject.org/updates/python-pygments-1.1.1-1.el4

Please help verify it works as expected.

Comment 6 Fedora Update System 2009-10-02 05:07:09 UTC
python-pygments-1.1.1-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-pygments'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0569

Comment 7 Nils Breunese 2009-10-05 14:20:28 UTC
The python-pygments-1.1.1-1.el4 package in epel-testing works fine for me.

Comment 8 Steve Milner 2009-10-08 14:21:10 UTC
Just marked as stable. Will update when it hits stable.

Comment 9 Fedora Update System 2009-10-08 23:26:55 UTC
python-pygments-1.1.1-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-pygments'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0569

Comment 10 Fedora Update System 2009-10-23 23:19:48 UTC
python-pygments-1.1.1-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.