Bug 526320 - ppc64.img and ppc32.img missing from tree
Summary: ppc64.img and ppc32.img missing from tree
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-09-29 19:48 UTC by James Laska
Modified: 2013-09-02 06:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-09 15:52:45 UTC
Type: ---


Attachments (Terms of Use)

Description James Laska 2009-09-29 19:48:52 UTC
Description of problem:

.treeinfo points to a zimage file for ppc32 that is not present in the tree.  Additionally, .treeinfo is missing a zimage entry for ppc64.img (which is also missing from the tree).  These files were present in F-12-Alpha and are causing rats_install to fail the install image check (see https://fedorahosted.org/pipermail/autoqa-results/2009-September/001181.html)

Version-Release number of selected component (if applicable):

 * rawhide-20090929

How reproducible:


Steps to Reproduce:
1. curl http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/.treeinfo

Actual results:

....
[images-ppc64]
initrd = ppc/ppc64/ramdisk.image.gz
kernel = ppc/ppc64/vmlinuz

[images-ppc]
initrd = ppc/ppc32/ramdisk.image.gz
zimage = images/netboot/ppc32.img
kernel = ppc/ppc32/vmlinuz


Expected results:

[images-ppc64]
initrd = ppc/ppc64/ramdisk.image.gz
kernel = ppc/ppc64/vmlinuz
zimage = images/netboot/ppc64.img

[images-ppc]
initrd = ppc/ppc32/ramdisk.image.gz
zimage = images/netboot/ppc32.img
kernel = ppc/ppc32/vmlinuz


Additional info:

Comment 1 James Laska 2009-09-30 11:38:44 UTC
The more I think about this, the more I think this makes sense as a beta blocker.  These images were present in F-12-Alpha and are used by IBM for installation.  Unintentionally dropping installation images between F-12-Alpha nd F-12-Beta seems to be something we can/should avoid.

Comment 2 Jesse Keating 2009-09-30 18:18:14 UTC
I did some minor looking into this, but I'm going to need access to some fast PPC machinery to really dig into it.  I'm trying to arrange that today to run buildinstall in debug mode to see why the zimage call is failing for ppc64.

Comment 3 Jesse Keating 2009-10-02 22:07:04 UTC
Ok, there are multiple things going on here.

Previously, the 32bit bootwrapper file was used to create both the ppc64.img and the ppc32.img file.  Apparently this was wrong and a change was committed to fix this ( http://git.fedorahosted.org/git/anaconda/?p=anaconda.git;a=commit;h=cfc7d65e177778de6bec27e708c28bad3ae88c03 ) to use the proper arch's wrapper file.  However in Fedora, kernel-bootwrapper isn't multilib, so there is only the ppc32 package in the tree.  Not only that, but if the ppc64 wrapper call fails, the netboot/ directory is never created, and thus the subsequent ppc32 wrapper call (which should succeed) will also fail, leaving no images.

To fix this, we need to make sure the ppc64 version of kernel-bootwrapper gets installed into the chroot made by upd-instroot.  Optionally we can fix the 32bit wrapper call to make sure the netboot directory is there before trying to use it.

Comment 4 Jesse Keating 2009-10-02 23:18:42 UTC
I sent a patch to at least get the 32bit netboot image created again, and to keep from putting a image file that doesn't exist in the .treeinfo file.

Comment 5 Jesse Keating 2009-10-05 19:49:10 UTC
A final patch sent that should make this code set work both on a 32bit userland and a 64bit userland.  Testing the netboot image made of a 64bit kernel using the 32bit bootwrapper, but if it worked at Alpha, it should continue to work now.

Comment 6 James Laska 2009-10-05 20:36:08 UTC
Tested a ppc64.img provided by jkeating (http://kojipkgs.fedoraproject.org/mash/rawhide-20090924/development/ppc/os/images/netboot/ppc64.img).  This image fails to properly boot, but so does F-12-Alpha (F-11-GOLD works).  This will need to be tracked in a different bug and is outside the scope of the reported issue.

Comment 7 Jesse Keating 2009-10-06 16:47:55 UTC
Ok, so I'm not sure this should block Beta, especially if it hasn't worked since at least Alpha.  I guess we'll have to pinpoint when it stopped working.

Actually this bug was mostly about the images not showing up.  I think we can close this particular bug, and open a new one for the images not functioning.  James, can you file a new bug with the data from the non-boot?

Comment 8 James Laska 2009-10-06 17:23:58 UTC
(In reply to comment #7)
> Ok, so I'm not sure this should block Beta, especially if it hasn't worked
> since at least Alpha.  I guess we'll have to pinpoint when it stopped working.
> Actually this bug was mostly about the images not showing up.  

> I think we can
> close this particular bug, and open a new one for the images not functioning. 
> James, can you file a new bug with the data from the non-boot?  

I agree, no objections.  The new bug to track ppc64.img not booting is bug#527506

Comment 9 James Laska 2009-10-09 13:55:34 UTC
(In reply to comment #5)
> A final patch sent that should make this code set work both on a 32bit userland
> and a 64bit userland.  Testing the netboot image made of a 64bit kernel using
> the 32bit bootwrapper, but if it worked at Alpha, it should continue to work
> now.  

'm not seeing ppc64.img in current (or recent rawhide) since this issue was closed.  Has the patch been accepted?

Comment 10 James Laska 2009-10-09 15:52:45 UTC
Looks like it's there now with the *latest* rawhide compose.  

http://kojipkgs.fedoraproject.org/mash/rawhide-20091009/development/ppc/os/images/netboot/


Note You need to log in before you can comment on or make changes to this bug.