Bug 52634 - mount doesn't always show the correct fs type
mount doesn't always show the correct fs type
Status: CLOSED DUPLICATE of bug 52299
Product: Red Hat Public Beta
Classification: Retired
Component: mount (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 10:57 EDT by Stephen Tweedie
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 10:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2001-08-27 10:57:28 EDT
Description of Problem:

Mount usually shows the fstype in /etc/fstab, not the actual fs type from
/proc/mounts, for the root filesystem.

This is a serious problem because there is a common failure mode where
people think they have upgraded to ext3 but haven't built a new initrd, so
the root fs is actually loaded as ext2 despite "mount" claiming that it is
mounted as ext3.

Version-Release number of selected component (if applicable):
mount-2.11g-5

How Reproducible:
100%

Steps to Reproduce:
1. Convert to ext3 on root filesystem (with ext3 in /etc/fstab)
2. Boot a kernel without an initrd (so we don't have an ext3 module loaded)
   The kernel loads the root filesystem as ext2, not ext3, as expected.
3. Run "mount" to display mounted filesystems.

Actual Results:
[sct@dax] ~ $ mount
/dev/hdc1 on / type ext3 (rw,usrquota,grpquota)

but in actual fact it is an ext2 filesystem:

[sct@dax] ~ $ cat /proc/mounts 
/dev/root / ext2 rw 0 0


Expected Results:

mount should display what IS mounted, not just what it thinks OUGHT to be
mounted.

Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-08-28 10:07:24 EDT
What does your /etc/mtab say?
Comment 2 Bernhard Rosenkraenzer 2001-09-03 07:34:27 EDT

*** This bug has been marked as a duplicate of 52299 ***

Note You need to log in before you can comment on or make changes to this bug.