This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526366 - applications hang when trying to connect to /dev/gpmctl [NEEDINFO]
applications hang when trying to connect to /dev/gpmctl
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gpm (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jaromír Cápík
qe-baseos-daemons
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 20:57 EDT by Josh Hunt
Modified: 2014-06-02 09:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:08:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (josh)


Attachments (Terms of Use)

  None (edit)
Description Josh Hunt 2009-09-29 20:57:15 EDT
Description of problem:

I have an application using dialog.  When it is run from xterm using TERM=vt100 nothing is displayed on the terminal.  The app appears to be hung.  When I strace the dialog process I see the following:

root@ssh92 ~]# strace -p 25452
Process 25452 attached - interrupt to quit
connect(4, {sa_family=AF_FILE, path="/dev/gpmctl"...}, 13

When I run netstat -x I see the following:
[root@ssh92 tmp]# netstat -x | grep gpm
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl
unix  3      [ ]         STREAM     CONNECTING    0      /dev/gpmctl

Apparently this is a well-known issue and has been seen in other bugs reported here with midnight commander.  I have verified that with the latest version of gpm, 1.20.6 (from http://linux.schottelius.org/gpm/), the issue appears to go away.  I have not tried to narrow down which commit fixes this issue.  I would like to see the gpm package updated to a version which fixes this issue in the next release of RHEL5.

Version-Release number of selected component (if applicable):

[root@ssh92 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.3 (Tikanga)

[root@ssh92 ~]# uname -a
Linux ssh92 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@ssh92 ~]# rpm -qa | grep gpm
gpm-1.20.1-74.1
gpm-devel-1.20.1-74.1

How reproducible:
It is very reproducible on my system (a freshly installed RHEL5.3 install.)  It will usually occur after about 7 or 8 runs of the dialog program.

Steps to Reproduce:
1) launch gnome-terminal in X
2) in gnome-terminal run xterm (not sure if this step is needed)
3) set TERM to vt100 - export TERM=vt100
4) run dialog --infobox "hello" 20 20, will probably need to be run 7-8 times before the issue reproduces.  
 
Actual results:
Application is hung, nothing displayed.

Expected results:
Application is expected to run.


Additional info:
I believe this issue is already detailed here:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=470882
Comment 1 Josh Hunt 2009-10-02 12:54:09 EDT
Correcting summary.  It's not that gpm hangs, but applications are hanging due to gpm.
Comment 2 RHEL Product and Program Management 2009-11-06 14:01:18 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2010-08-09 15:08:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-05-31 10:25:33 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Arnaud Lacombe 2012-12-27 12:15:51 EST
From Fedora 16, restarting gpm did the trick:

# sudo service gpm restart
Comment 7 Jaromír Cápík 2013-01-09 11:25:03 EST
Hello Josh.
I just tried to do a local update to 1.20.3 and 1.20.4.

Results:
I was able to reproduce the issue with 1.20.3.
I was unable to reproduce the issue with 1.20.4.

I'm gonna read the debian thread you mentioned in the additional info and apply relevant patches.

Thank you for the report.

Regards,
Jaromir.
Comment 8 Jaromír Cápík 2013-01-10 06:19:16 EST
Apparently the code went through a massive redesign with 1.20.3 release and it's impossible to solve the issue by adopting patches from the mentioned thread or other sites. The differential patch has nearly 1MB in size. Moreover the library version changed from 1.19.0 to 2.0.0 between the relevant releases (1.20.1 - 1.20.4) and we would have to rebuild all packages linked against libgpm. I'm gonna discuss this issue with the previous gpm maintainer, but it seems there's no easy solution for this issue. We could potentially introduce more serious problems with such update.
Comment 9 RHEL Product and Program Management 2014-03-07 07:44:55 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 10 RHEL Product and Program Management 2014-06-02 09:08:22 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.