Bug 52638 - Defective HPFS driver
Defective HPFS driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 11:39 EDT by G.S. Link
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 23:25:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.S. Link 2001-08-27 11:39:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; I)

Description of problem:
The HPFS file system driver supplied on both the 6 and 7 disks is defective.
It reads an HPFS partition correctly.  It correctly writes the first file on the partition
but then fails.  This locks the partition until CHKDSK is run in OS/2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Mount HPFS partition
2. Write on partition
3. Note that partition is now locked and must be unlocked with OS/2 CHKDSK
	

Actual Results:  What I said would happen.

Additional info:
Comment 1 Alan Cox 2001-08-27 11:52:29 EDT
We should probably just pull HPFS from the kernel. It isnt maintained and nobody
seems to be planning to support it into 2.5 anyway.
Comment 2 Michael K. Johnson 2001-08-27 12:03:13 EDT
Agreed, pull.
Comment 3 G.S. Link 2001-08-28 09:24:51 EDT
I suppose that is one way to resolve the problem but it significantly decreases the usefulness
of Linux as an OS/2 replacement.  If I can't talk to OS/2 Migration problems increase. 
 When I ran our system tests against 7.1 there were lots of problems similar to this one.
If you cut out every defective part you won't have much left.

Note You need to log in before you can comment on or make changes to this bug.