Bug 526380 - Xorg update kills graphics
Xorg update kills graphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-09-29 23:57 EDT by Sean Middleditch
Modified: 2009-10-02 15:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 11:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log from failed startup (50.63 KB, text/plain)
2009-09-29 23:57 EDT, Sean Middleditch
no flags Details

  None (edit)
Description Sean Middleditch 2009-09-29 23:57:19 EDT
Created attachment 363114 [details]
Xorg log from failed startup

Description of problem:

With xorg-x11-server-Xorg 1.6.99.903-1.fc12 on Rawhide with an ATI HD4770 video card (using xorg-x11-drv-ati driver), X can no longer start.  Downgrading to 1.6.99.902-1.fc12 fixes the issue.

Version-Release number of selected component (if applicable):

1.6.99.903-1.fc12

How reproducible:

Happens every single time.

Steps to Reproduce:
1. update xorg-x11-server-Xorg to the 1.6.99.903 version
2. restart X
3. watch it fail
  
Actual results:

X begins to start like normal after Plymouth.  The mouse cursor shows up.  Then the screen goes black.  A second or two later, the mouse cursor is visible again.  Then it goes black.  Repeat ad nauseum.  Switching to a different virtual console gives evidence that X is restarting, because almost instantly after switching X will try to start again, and in the annoying way that it does it switches its own virtual console, so trying to log in on the console is quite an ordeal.

Expected results:

X to finish starting and bring up GDM like it does with the .902 version.

Additional info:

I'm running an ATI HD4770 with the -ati driver.  The system is x86_64.  Various component versions that may be of interest:

xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.x86_64
kernel-2.6.31-33.fc12.x86_64
mesa-libGL-7.6-0.13.fc12.x86_64
mesa-dri-drivers-7.6-0.13.fc12.x86_64
gdm-2.28.0-4.fc12.x86_64

The Plymouth KMS stuff all works perfectly fine.  Just X fails to start.  Fails using the regular run level 5 boot up to GDM or when trying to use startx after booting into run level 3.

I tried booting with different kernel versions and downgrading the -ati driver, but they had no effect.  If I use the 1.6.99.903 version of Xorg it fails to come up while if I use a previous version of Xorg it works just fine.
Comment 1 Yanko Kaneti 2009-09-30 02:21:46 EDT
903 unbroke here. Looks like to the new radeon update "fixed" it
xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12.x86_64
Comment 2 Paul W. Frields 2009-09-30 08:51:49 EDT
Same problem occurred here with rv770-based ATI Radeon HD 4850 [1002:9442], and same solution as in comment #1 above.
Comment 3 A S Alam 2009-09-30 10:00:38 EDT
xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12.x86_64  fixes the Isssue
Comment 4 Espen Stefansen 2009-09-30 12:36:07 EDT
xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12.x86_64 does not fix the issue for me. But downgrading to xorg-x11-server-Xorg-1.6.99.902-1.fc12.i686 fixes it.

kernel:
kernel-PAE-2.6.31.1-56.fc12.i686

lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
Comment 5 Paul W. Frields 2009-09-30 13:41:05 EDT
For what it's worth, *either* upgrading to the new xorg-x11-drv-ati *or* downgrading to the previous xorg-x11-server-Xorg worked in my case (see comment #2 above).
Comment 6 Yanko Kaneti 2009-09-30 14:39:05 EDT
I have no idea what "mixed" is (see -ati's changelog) but the same the thing between .902 and .903 that broke r600, has also broken previous r's. In my case RS690M is broken with .903 +  -ati -0.6 in the same way described in this report.

So I tried copying the mixed disabling for the older radeon's in radeon_exa_funcs.c 

-#ifdef EXA_MIXED_PIXMAPS
-	info->accel_state->exa->flags |= EXA_MIXED_PIXMAPS;
-#endif
+//#ifdef EXA_MIXED_PIXMAPS
+//	info->accel_state->exa->flags |= EXA_MIXED_PIXMAPS;
+//#endif

and it helped.
Comment 7 Michal Schmidt 2009-09-30 17:34:07 EDT
I have the same situation as Yanko: RS690M - only downgrading the X server to .902 helps. Having xorg-x11-drv-ati -0.6 from Koji does NOT help.

I'm setting the bug status back to NEW. (VERIFIED is not even applicable for Fedora, see https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow)
Comment 8 Michal Jaegermann 2009-09-30 18:09:52 EDT
The same thing with "ATI Technologies Inc R300 AD [Radeon 9500 Pro]".  Moreover attempts to start 1.6.99.903-1.fc12 totally kill video and I am left with black monitor blinking "no signal".

If I boot to level 5 then I see logs which look basically the same as https://bugzilla.redhat.com/attachment.cgi?id=363114. OTOH I I will boot to level 3 and will try 'startx' then the last log line is

(II) RADEON(0): EDID for output S-video

and after that video is gone.  Booting with older kernels does not help.

A revert to xorg-x11-server-1.6.99.902-1.fc12 makes things to work again; also with xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12 driver.
Comment 9 Dave Airlie 2009-10-01 02:00:20 EDT
new X server being built to address this

xorg-x11-server-1_6_99_903-2_fc12
Comment 10 Michal Schmidt 2009-10-01 03:02:01 EDT
Dave,
xorg-x11-server-Xorg-1.6.99.903-2.fc12.x86_64 fixes the bug for me.
I see you've already filed a rel-eng ticket to have it moved to F12 Beta. Thanks.
Comment 11 Gene Czarcinski 2009-10-02 00:15:02 EDT
+1
ati RV370 [Radeon X300]
xorg-x11-server-Xorg-1.6.99.903-1.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12.x86_64
Comment 12 Adam Williamson 2009-10-02 11:51:07 EDT
not closing till we confirm the build is tagged for beta.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2009-10-02 11:53:00 EDT
oxf13 confirms a newer build is already tagged. closing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2009-10-02 11:53:12 EDT
https://fedorahosted.org/rel-eng/ticket/2250

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Gene Czarcinski 2009-10-02 15:27:12 EDT
confirmed, fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.