Bug 526405 - Can't assign RAW Queue driver to printer
Summary: Can't assign RAW Queue driver to printer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 05:51 UTC by Rich Rauenzahn
Modified: 2009-10-14 02:01 UTC (History)
3 users (show)

Fixed In Version: 1.4.1-4.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 02:01:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 3356 None None None Never

Description Rich Rauenzahn 2009-09-30 05:51:06 UTC
Description of problem:

I can't assign the Generic RAW "Driver" to my printer.  I walk through the menus, but it always retains the previous driver installed.  (i.e., if I select Generic Text Only, then go back again to assign RAW, it stays with Generic Text Only.)

Version-Release number of selected component (if applicable):

[rrauenza@tendo yum.repos.d]$ rpm -qi system-config-printer cups hplip
Name        : system-config-printer        Relocations: (not relocatable)
Version     : 1.1.13                            Vendor: Fedora Project
Release     : 2.fc11                        Build Date: Tue 22 Sep 2009 03:46:53 AM PDT
Install Date: Tue 29 Sep 2009 10:40:03 PM PDT      Build Host: x86-7.fedora.phx.redhat.com
Group       : System Environment/Base       Source RPM: system-config-printer-1.1.13-2.fc11.src.rpm
Size        : 1836828                          License: GPLv2+
Signature   : RSA/8, Tue 22 Sep 2009 08:34:26 AM PDT, Key ID 1dc5c758d22e77f2
Packager    : Fedora Project
URL         : http://cyberelk.net/tim/software/system-config-printer/
Summary     : A printer administration tool
Description :
system-config-printer is a graphical user interface that allows
the user to configure a CUPS print server.
Name        : cups                         Relocations: (not relocatable)
Version     : 1.4                               Vendor: Fedora Project
Release     : 0.rc1.15.fc11                 Build Date: Tue 11 Aug 2009 01:16:19 AM PDT
Install Date: Sat 26 Sep 2009 11:24:26 AM PDT      Build Host: x86-7.fedora.phx.redhat.com
Group       : System Environment/Daemons    Source RPM: cups-1.4-0.rc1.15.fc11.src.rpm
Size        : 10747422                         License: GPLv2
Signature   : RSA/SHA1, Tue 11 Aug 2009 05:27:30 AM PDT, Key ID 1dc5c758d22e77f2
Packager    : Fedora Project
URL         : http://www.cups.org/
Summary     : Common Unix Printing System
Description :
The Common UNIX Printing System provides a portable printing layer for
UNIX® operating systems. It has been developed by Easy Software Products
to promote a standard printing solution for all UNIX vendors and users.
CUPS provides the System V and Berkeley command-line interfaces.
Name        : hplip                        Relocations: (not relocatable)
Version     : 3.9.8                             Vendor: Fedora Project
Release     : 12.fc11                       Build Date: Fri 28 Aug 2009 04:09:57 AM PDT
Install Date: Sat 26 Sep 2009 11:33:17 AM PDT      Build Host: x86-3.fedora.phx.redhat.com
Group       : System Environment/Daemons    Source RPM: hplip-3.9.8-12.fc11.src.rpm
Size        : 9007902                          License: GPLv2+ and MIT
Signature   : RSA/SHA1, Fri 28 Aug 2009 04:55:05 AM PDT, Key ID 1dc5c758d22e77f2
Packager    : Fedora Project
URL         : http://hplip.sourceforge.net/
Summary     : HP Linux Imaging and Printing Project
Description :
The Hewlett-Packard Linux Imaging and Printing Project provides
drivers for HP printers and multi-function peripherals.
[rrauenza@tendo yum.repos.d]$ 

How reproducible:

Every time on my system.

Steps to Reproduce:
0. Open system-config-printer
1. Add Printer (HP color 2500 in my case), allow default driver
2. Add 2nd instance of same printer
3. Assign Generic/RAW Queue to 2nd instance
  
Actual results:

Previous driver is still assigned

Expected results:

RAW driver should be assigned

Additional info:

In case it matters, this system is an upgrade from FC10

Comment 1 Rich Rauenzahn 2009-09-30 06:52:41 UTC
Did some more debugging tonight.  

First, the cups port 631 web interface doesn't have a RAW ppd to select as well.

But I'm reading that that may be by design...that is that RAW doesn't have a PPD.  ...and through a couple of iterations I found the ppd in /etc/cups/ppd/ was actually removed (at least one of the times) when I select RAW in system-config-printer -- which I also believe is as designed, i.e., RAW is by definition no PPD.

Removing it manually earlier (via rm), though, seemed to cause this error:

E [29/Sep/2009:23:18:14 -0700] [CGI] Unable to get PPD file /printers/hp-color-LaserJet-2500-RAW.ppd: 404 - Not Found

The GUI's don't seem to reflect this model at all.... I don't see a way to select RAW in the cups 631 web interface, and system-config-printer lets you select it, but the GUI doesn't reflect it, leading you to believe the previous driver is still active.

(Someday I hope to do a Fedora upgrade from X to Y and have my printer share not break in the process...)

Comment 2 Tim Waugh 2009-09-30 12:56:34 UTC
(In reply to comment #1)
> First, the cups port 631 web interface doesn't have a RAW ppd to select as
> well.

It does (or should have): look for 'Raw' in the list of manufacturers.

(In system-config-printer we move it from 'Raw' to 'Generic'.)

> The GUI's don't seem to reflect this model at all.... I don't see a way to
> select RAW in the cups 631 web interface, and system-config-printer lets you
> select it, but the GUI doesn't reflect it, leading you to believe the previous
> driver is still active.

This is a CUPS bug: PPDs are cached to avoid having to re-parse them often.  In the case of changing the driver for a queue from some PPD to 'raw', there is no PPD to load -- but CUPS was loading the cached PPD from before the change.

> (Someday I hope to do a Fedora upgrade from X to Y and have my printer share
> not break in the process...)  

Please elaborate.  The upgrade process is not intentionally changing any PPDs except those provided by gutenprint-cups, which has an upgrade script to make sure they are valid even if options change.

In what way have you experienced broken queues on upgrade?

Comment 3 Fedora Update System 2009-09-30 14:20:15 UTC
cups-1.4.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cups-1.4.1-1.fc11

Comment 4 Rich Rauenzahn 2009-09-30 14:36:08 UTC
Unfortunately I can't be very specific as this is over several years and several upgrades (FCX to FCY, not patches within an FCX)   

One FC version had the wrong I/O config for the lj2500 in hplip and it could't print to it -- for a while I just ran with the FCX-1's hplip.  I worked directly with the folks from HP to fix that one.  Another upgrade the printers didn't work until I removed them all and re-added them.

This time my printer in the queue kept going into a down state, and rather than debug, I deleted them and re-added them to see if it fixed it, and then found the RAW problem with the re-add.  I also noticed this time the printer paths change to hp:// from ... usb:// or something else?  Wasn't sure if that was relevant to the problem.

The amount of time I have spent fixing print queues has convinced me the next printer I buy will definitely have a network port...

Comment 5 Rich Rauenzahn 2009-09-30 16:19:49 UTC
> It does (or should have): look for 'Raw' in the list of manufacturers.
> (In system-config-printer we move it from 'Raw' to 'Generic'.)

You may be right and I can't check right now.  I assumed "Raw" would be under "Generic" in the 631 interface just like the system-config-printer one.  I'm inclined to argue they should be organized the same way in both interfaces.

Thanks for the work you guys do on this stuff.

Comment 6 Fedora Update System 2009-10-01 00:06:37 UTC
cups-1.4.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10152

Comment 7 Fedora Update System 2009-10-03 18:59:58 UTC
cups-1.4.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10152

Comment 8 Fedora Update System 2009-10-09 03:37:08 UTC
cups-1.4.1-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10152

Comment 9 Fedora Update System 2009-10-14 02:00:37 UTC
cups-1.4.1-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.