Bug 526411 - The SCSI failed 2008 R2 DP WDK Hot-Add Device Test—Verify driver support for Hot-Add CPU
Summary: The SCSI failed 2008 R2 DP WDK Hot-Add Device Test—Verify driver support for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 518435
TreeView+ depends on / blocked
 
Reported: 2009-09-30 06:56 UTC by koka xiong
Modified: 2011-02-01 09:00 UTC (History)
6 users (show)

Fixed In Version: xenpv-win-1.3.1-1.el5
Doc Type: Bug Fix
Doc Text:
Previously, running the "WDK Hot-Add—Verify driver support for Hot-Add CPU" from the Windows Logo Kit on RHELSCSI driver caused the windows guest to crash. With this update, the RHELSCSI driver passes the "WDK Hot-Add—Verify driver support for Hot-Add CPU" from the Windows Logo Kit.
Clone Of:
Environment:
Last Closed: 2011-02-01 09:00:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0187 normal SHIPPED_LIVE xenpv-win bug fix update 2011-02-01 08:59:58 UTC

Description koka xiong 2009-09-30 06:56:21 UTC
Description of problem:
The SCSI failed 2008 R2 DP WDK-Hot-Add Device Test-Verify driver support for Host-Add CPU

Version-Release number of selected component (if applicable):
xenpv-win-64-bit-1.0.90-2.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Configure WHQL and do NIC 2008R2 DP WDK-Hot-Add Device Test-Verify driver support for Host-Add CPU
2.The test will failed
3.
  
Actual results:


Expected results:


Additional info:
Title Result 
  Failed 
 Start Test 9/29/2009 4:25:07.929 PM One instance of the device must not be on the paging path 
Message 9/29/2009 4:25:07.929 PM Checking device "PCI\VEN_5853&DEV_0001&SUBSYS_00015853&REV_01\3&267A616A&0&18" 
Message 9/29/2009 4:25:07.929 PM Enumerating child devices. 
Message 9/29/2009 4:25:07.929 PM Checking device "SCSI\DISK&VEN_RHEL&PROD_DISK\4&32FE5319&0&000000" 
Message 9/29/2009 4:25:07.929 PM Device is a disk, getting volumes 
Message 9/29/2009 4:25:07.929 PM Volume STORAGE\VOLUME\{45BF45A5-ACEC-11DE-BE95-806E6F6E6963}#0000000000100000 does not contain pagefile 
Message 9/29/2009 4:25:08.929 PM Volume STORAGE\VOLUME\{45BF45A5-ACEC-11DE-BE95-806E6F6E6963}#0000000006500000 contains pagefile 
Message 9/29/2009 4:25:08.929 PM Checking device "SCSI\DISK&VEN_RHEL&PROD_DISK\4&32FE5319&0&000004" 
Message 9/29/2009 4:25:08.929 PM Device is a disk, getting volumes 
Message 9/29/2009 4:25:08.929 PM Disk has no volumes 
Message 9/29/2009 4:25:08.929 PM Pagefile was not found on "SCSI\DISK&VEN_RHEL&PROD_DISK\4&32FE5319&0&000004" or any child devices. 
Message 9/29/2009 4:25:08.929 PM Checking device "SCSI\NET&VEN_RHEL&PROD_NIC\4&32FE5319&0&000081" 
Message 9/29/2009 4:25:08.929 PM Enumerating child devices. 
Message 9/29/2009 4:25:08.929 PM Pagefile was not found on "SCSI\NET&VEN_RHEL&PROD_NIC\4&32FE5319&0&000081" or any child devices. 
Message 9/29/2009 4:25:08.929 PM PCI\VEN_5853&DEV_0001&SUBSYS_00015853&REV_01\3&267A616A&0&18 is on the paging path, excluding 
End Test 9/29/2009 4:25:08.929 PM One instance of the device must not be on the paging path 
Result:   Fail 
Repro:   Pagepath, Version=6.1.0.0, Culture=neutral, PublicKeyToken=null /driver rhelscsi /not 
 
  Failed 
 Start Test 9/29/2009 4:25:08.929 PM Device instance must have disk storage connected 
End Test 9/29/2009 4:25:08.929 PM Device instance must have disk storage connected 
Result:   Fail 
Repro:   Pagepath, Version=6.1.0.0, Culture=neutral, PublicKeyToken=null /driver rhelscsi /not

Comment 1 Paolo Bonzini 2009-11-04 10:36:31 UTC

*** This bug has been marked as a duplicate of bug 532865 ***

Comment 2 Paolo Bonzini 2010-10-29 16:51:39 UTC
This still happens according to the latest testing from QE, with a memory leak (STOP 0x4E4558 which is triggered by the drivers).

Waiting on more info or screenshots...

Comment 4 Paolo Bonzini 2010-10-31 12:16:35 UTC
Ok, I reproduced it.

Comment 5 Rita Wu 2010-11-01 13:22:46 UTC
When I testing Win2k8-r2 with xenpv-win-1.3.0-1, I met BSOD(stop-0x4E4558)
frequently when doing 3 child jobs of Plug and Play Driver Test-Library Job,
there are:

STORAGE:Detect if device is a boot/page parent adapter
Run Remove PNPD Test 
Run Surprise PNPD Test

Comment 7 Paolo Bonzini 2010-11-09 19:35:43 UTC
Patch posted on Nov 1st.

Comment 9 cshao 2010-11-24 07:43:08 UTC
Test Version-Release number of selected component:
xenpv-win-1.3.1.iso
xen-3.0.3-119.el5
kernel-xen-2.6.18-232.el5

Test steps:
1. Configure WHQL and do NIC 2008R2 DP WDK-Hot-Add Device Test-Verify driver
support for Host-Add CPU
2. Set the DWORD value "EnumerateDevicesOverride" to 3 in  the registry key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\rhelscsi.

Test Result:
PASS

So change bug status to VERIFIED.

Comment 10 cshao 2010-11-24 07:50:41 UTC
Test platform: windows 2008-64 and win2008R2

Comment 11 Florian Nadge 2011-01-03 16:12:58 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, running the "WDK Hot-Add—Verify driver support for Hot-Add CPU" from the Windows Logo Kit on RHELSCSI driver caused the windows guest to crash. With this update, the RHELSCSI driver passes the "WDK Hot-Add—Verify driver support for Hot-Add CPU" from the Windows Logo Kit.

Comment 12 errata-xmlrpc 2011-02-01 09:00:32 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0187.html


Note You need to log in before you can comment on or make changes to this bug.