Bug 526433 - [KMS] X crashes on ATI Radeon X800 (R420)
[KMS] X crashes on ATI Radeon X800 (R420)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 04:57 EDT by Joachim Frieben
Modified: 2009-10-04 15:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-server-Xorg-1.6.99.903-2.fc12.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-04 15:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log for ATI Radeon X800 (R420) with KMS (48.68 KB, text/plain)
2009-09-30 05:27 EDT, Joachim Frieben
no flags Details
Output of dmesg for ATI Radeon X800 (R420) with KMS and drm.debug=0x0f (49.36 KB, text/plain)
2009-10-03 04:57 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-09-30 04:57:28 EDT
Description of problem:
For a current "rawhide" system sporting an "ATI Radeon X800 SE (R430) (PCIE)", X is broken when KMS is enabled. The system boots up as expected but gets stuck in a cycle of failed attempts to bring up X/GDM. Log file /var/log/messages exhibits the following recurrent section:

  ..
  kernel: integrated sync not supported
  kernel: [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
  kernel: [drm] DAC-10: set mode 1400x1050@75 2d
  kernel: integrated sync not supported
  kernel: integrated sync not supported
  kernel: integrated sync not supported
  abrtd: Directory 'ccpp-1254287712-1984' creation detected
  abrtd: Lock file '/var/cache/abrt/ccpp-1254287712-1984.lock' is locked
           by process 2024
  abrt: saved core dump of pid 1984 to
           /var/cache/abrt/ccpp-1254287712-1984/coredump
  gdm-simple-greeter[2022]: Gtk-WARNING: cannot open display: :3.0
  gdm-simple-slave[1983]: WARNING: Child process -2005 was already dead.
  gdm-simple-slave[1983]: WARNING: Unable to kill D-Bus daemon
  gdm-binary[1790]: WARNING: GdmDisplay: display lasted 2.660207 seconds
  abrtd: Getting local universal unique identification...
  kernel: integrated sync not supported
  abrtd: Crash is in database already
  abrtd: Already saved crash, deleting...
  kernel: integrated sync not supported
  ..

Version-Release number of selected component (if applicable):
kernel-2.6.31.1-56.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot kernel 2.6.31.1-56.fc12 with active KMS.
  
Actual results:
When X is supposed to be launched, the system enters a cycle of failed attempts to bring up GDM.

Expected results:
X starts up successfully, and the GDM login panel appears on the screen.

Additional info:
Booting the system with option "nomodeset" allows to start X without issues.
Comment 1 Joachim Frieben 2009-09-30 05:27:16 EDT
Created attachment 363158 [details]
Xorg.0.log for ATI Radeon X800 (R420) with KMS

After booting into run level 3, executing 'startx' leads to a mouse pointer appearing in front of a black background. However, after a moment, the monitor (21" CRT HP A4576A) powers off. The system does not respond to ctrl-alt-del. Nevertheless, it is still possible to shut down the system in a controlled manner by pressing the soft power button.
Comment 2 Paul Bolle 2009-09-30 19:03:41 EDT
0) Similar issue with a "Radeon RV250 [Mobility FireGL 9000]" on an i686 system. "nomodeset" seems to be a workaround here too.

1) Not sure if its kernel related per se. I now see identical issues on both kernel-2.6.31.1-48.fc12.i686 and kernel-2.6.31.1-56.fc12.i686. At least I first noticed this with kernel-2.6.31.1-56.fc12.i686, but as kernel-2.6.31.1-48.fc12.i686 didn't trigger this issue before, I suppose one of the xorg packages that came in the same batch of updates as kernel-2.6.31.1-56.fc12.i686 (e.g. xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12, xorg-x11-server-Xorg-1.6.99.903-1.fc12, and xorg-x11-server-common-1.6.99.903-1.fc12) could also be the culprit.
Comment 3 Joachim Frieben 2009-10-03 04:57:48 EDT
Created attachment 363545 [details]
Output of dmesg for ATI Radeon X800 (R420) with KMS and drm.debug=0x0f
Comment 4 Paul Bolle 2009-10-04 04:14:12 EDT
(In reply to comment #2)
> 1) [...] I suppose one of
> the xorg packages that came in the same batch of updates as
> kernel-2.6.31.1-56.fc12.i686 (e.g.
> xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12,
> xorg-x11-server-Xorg-1.6.99.903-1.fc12, and
> xorg-x11-server-common-1.6.99.903-1.fc12) could also be the culprit.  

Issue seems to be resolved here (with a "Radeon RV250 [Mobility FireGL 9000]" on an i686 system) with xorg-x11-server-Xorg-1.6.99.903-2.fc12.i686 and friends (i.e., the current Rawhide packages). Can reporter confirm?

Note You need to log in before you can comment on or make changes to this bug.