Bug 526442 - add-printer method fails when using ppd-name and not device-uri
Summary: add-printer method fails when using ppd-name and not device-uri
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups-pk-helper
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 543006
TreeView+ depends on / blocked
 
Reported: 2009-09-30 09:49 UTC by Tim Waugh
Modified: 2009-12-01 13:24 UTC (History)
1 user (show)

Fixed In Version: 0.0.4-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 543006 (view as bug list)
Environment:
Last Closed: 2009-10-21 00:40:46 UTC


Attachments (Terms of Use)
cups-pk-helper-ppd-name.patch (1.32 KB, patch)
2009-09-30 10:30 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2009-09-30 09:49:31 UTC
Description of problem:
The device-uri attribute is not mandatory when using CUPS-Add-Printer, but cups-pk-helper-mechanism always fills in that field even when blank.  This causes the IPP request to fail.

Version-Release number of selected component (if applicable):
cups-pk-helper-0.0.4-7.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.cd /usr/share/system-config-printer
2.python
import authconn
authconn.set_debugging(True)
c=authconn.Connection()
c.addPrinter("foo", ppdname="raw")
3.Provide root password when asked by polkit authentication agent

Actual results:
An IPP authentication window is presented, and this debugging output can be seen in the terminal:

Connected as user twaugh
Authentication pass: 1
Authentication: password callback set
PolicyKit call to PrinterAdd did not work: client-error-not-possible
Authentication pass: 2
Forbidden: True
Authentication: Try as root
Connected as user root
PolicyKit call to PrinterAdd did not work: client-error-not-possible
Got password callback
Authentication pass: 3
Forbidden: False
cancelled
PolicyKit call to PrinterAdd did not work: client-error-not-possible

Comment 1 Tim Waugh 2009-09-30 10:30:27 UTC
Created attachment 363169 [details]
cups-pk-helper-ppd-name.patch

This patch fixes it for me.

Comment 2 Tim Waugh 2009-09-30 10:31:03 UTC
This affects F-11, F-12 and devel.

Comment 3 Marek Kašík 2009-10-02 07:38:01 UTC
Hi Tim,

thank you for the patch. I committed it to F-11, F-12 and devel.

Marek

Comment 4 Fedora Update System 2009-10-02 14:40:48 UTC
cups-pk-helper-0.0.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cups-pk-helper-0.0.4-5.fc11

Comment 5 Fedora Update System 2009-10-03 19:11:28 UTC
cups-pk-helper-0.0.4-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups-pk-helper'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10230

Comment 6 Tim Waugh 2009-10-05 11:47:29 UTC
Works for me.  Thanks.

Comment 7 Fedora Update System 2009-10-21 00:40:41 UTC
cups-pk-helper-0.0.4-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.