Bug 526472 - libvirt fails to enable IFF_VNET_HDR on tap fds for qemu-kvm
libvirt fails to enable IFF_VNET_HDR on tap fds for qemu-kvm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-09-30 10:12 EDT by Mark McLoughlin
Modified: 2009-10-06 23:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.6.2-18.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 23:08:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-09-30 10:12:13 EDT
See bug #522994

It seems that on F11, if you run a KVM guest with a virtio_net NIC using libvirt, GSO support is not enabled

Simplest way to check is to log in to the guest and run 'ethtool -k eth0' - if IFF_VNET_HDR is enabled, you'll see e.g. 'tcp-segmentation-offload: on'

The problem is that the code in libvirt-0.6.2 will only enable IFF_VNET_HDR if the qemu -help output displays something like:

  QEMU PC emulator version 0.9.1 (kvm-74)

whereas in F-11 it displays:

  QEMU PC emulator version 0.10.6 (qemu-kvm-0.10.6)

This was fixed upstream by the following commits:

  http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=04cbe68797
  http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=56ecebf22d

I'm going to backport those to F-11
Comment 1 Mark McLoughlin 2009-09-30 10:20:23 EDT
* Wed Sep 30 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-18
- Fix qemu-kvm version detection so GSO is enabled for virtio_net (#526472)
Comment 2 Fedora Update System 2009-09-30 10:37:09 EDT
libvirt-0.6.2-18.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libvirt-0.6.2-18.fc11
Comment 3 Fedora Update System 2009-09-30 20:02:07 EDT
libvirt-0.6.2-18.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10123
Comment 4 Fedora Update System 2009-10-06 23:08:33 EDT
libvirt-0.6.2-18.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.