Bug 526479 - Missing dependency on tdb-tools
Summary: Missing dependency on tdb-tools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ctdb
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Sumit Bose
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 5.5_Known-Issues
TreeView+ depends on / blocked
 
Reported: 2009-09-30 14:48 UTC by Paul te Bokkel
Modified: 2011-01-13 22:48 UTC (History)
5 users (show)

Fixed In Version: ctdb-1.0.82-2.el5
Doc Type: Bug Fix
Doc Text:
When installing ctdb, the tdb-tools package needs to be installed manually. This dependency issues will be addressed in a future release. (BZ#526479)
Clone Of:
Environment:
Last Closed: 2011-01-13 22:48:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0055 normal SHIPPED_LIVE ctdb bug fix update 2011-01-12 17:15:18 UTC

Description Paul te Bokkel 2009-09-30 14:48:12 UTC
Description of problem:
CTDB 1.0.82 is missing an depedency on tdb-tools.

Version-Release number of selected component (if applicable):
Name        : ctdb                         Relocations: (not relocatable)
Version     : 1.0.82                            Vendor: Red Hat, Inc.
Release     : 1.el5                         Build Date: Tue 19 May 2009 11:43:54 AM CEST
Install Date: Sun 27 Sep 2009 09:00:33 PM CEST      Build Host: hs20-bc1-7.build.redhat.com
Group       : System Environment/Daemons    Source RPM: ctdb-1.0.82-1.el5.src.rpm
Size        : 957103                           License: GPLv3+
Signature   : DSA/SHA1, Fri 31 Jul 2009 10:43:23 PM CEST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://ctdb.samba.org/
Summary     : A Clustered Database based on Samba's Trivial Database (TDB)


How reproducible:
Clean system, install and use CTDB and then try to restart it. It barfs with:
[root@TFILE001 ctdb]# /etc/init.d/ctdb start
Starting ctdbd service: Persistent database /var/ctdb/persistent/account_policy.tdb.1 is corrupted! CTDB will not start


Additional info:
In /etc/init.d/ctdb the databases are tested with /usr/bin/tdbdump, but if it's not installed, ctdb refuses to start.

Resolution:
Add dependency on tdb-tools.

Comment 1 Sumit Bose 2009-10-01 11:02:36 UTC
Set version to 5.5, because this is not a critical bug. As mentioned above, installing tdb-tools is an easy workaround.

Comment 3 Fedora Update System 2009-12-11 09:12:34 UTC
ctdb-1.0.108-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ctdb-1.0.108-1.fc12

Comment 5 Fedora Update System 2010-01-04 21:15:55 UTC
ctdb-1.0.108-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Sumit Bose 2010-03-15 13:21:32 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Known Issue: When installing ctdb, one needs to explicitly install tdb-tools as well. This dependency will be addressed in a future release.

Comment 10 Ryan Lerch 2010-03-19 01:54:40 UTC
Technical note updated. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Known Issue: When installing ctdb, one needs to explicitly install tdb-tools as well. This dependency will be addressed in a future release.+When installing ctdb, the tdb-tools package needs to be installed manually. This dependency issues will be addressed in a future release. (BZ#526479)

Comment 17 Nate Straz 2010-12-08 21:14:42 UTC
[root@west-04 ~]# yum install ctdb
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ctdb.x86_64 0:1.0.112-1.el5 set to be updated
--> Processing Dependency: tdb-tools for package: ctdb
--> Running transaction check
---> Package tdb-tools.x86_64 0:1.2.1-5.el5 set to be updated
--> Processing Dependency: libtdb = 1.2.1-5.el5 for package: tdb-tools
--> Running transaction check
---> Package libtdb.x86_64 0:1.2.1-5.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch         Version                Repository            Size
================================================================================
Installing:
 ctdb            x86_64       1.0.112-1.el5          ClusterStorage       439 k
Installing for dependencies:
 libtdb          x86_64       1.2.1-5.el5            Server                28 k
 tdb-tools       x86_64       1.2.1-5.el5            Server                80 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade       0 Package(s)

Total download size: 547 k
Is this ok [y/N]: y

Comment 19 errata-xmlrpc 2011-01-13 22:48:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0055.html


Note You need to log in before you can comment on or make changes to this bug.