Bug 526488 - virt-manager's 'Details' dialog has a poorly placed 'Remove' button
virt-manager's 'Details' dialog has a poorly placed 'Remove' button
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-09-30 11:21 EDT by Matthew Booth
Modified: 2009-12-03 18:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:52:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2009-09-30 11:21:08 EDT
Description of problem:
In the Details screen of virt-manager, the 'Remove' button is placed where GNOME dialogs put their 'Close' button. Not only that, but it doesn't prompt for confirmation. This has now caused me to delete 3 disk images!

For an example of why this button needs to be moved, look at the following dialogs on a F-11 system:
System->Preferences->Keyboard
System->Preferences->Sound
System->Preferences->Input Method

These were the first 3 I chose to compare with, and they all have their Close button at the bottom right. I expect they're all the same. The result is that I am now programmed to click on the button at the bottom right when I am no longer interested in the current window.

The lack of a confirmation dialog when deleting data is a separate bug.

Version-Release number of selected component (if applicable):
virt-manager-0.8.0-3.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open the Details pane of a virtual machine window
2. Select Disk, NIC, Mouse, Display, Serial or Video (and probably much more)
3. Click the button at the bottom right of the Window
  
Actual results:
Something is deleted

Expected results:
The current window is closed
Comment 1 Mark McLoughlin 2009-10-02 10:41:09 EDT
Yeah, I don't think that's a great place for the button, either - don't have any better suggestions though :)
Comment 2 Cole Robinson 2009-11-16 16:21:04 EST
Upstream has moved the button location to the left, since now we always show the 'Apply' button. Not that much better, but coupled with a confirmation for the remove button it should be all good.
Comment 3 Cole Robinson 2009-12-03 18:52:22 EST
This should be fixed in virt-manager-0.8.1-1.fc13 which will be in the next rawhide compose.

Note You need to log in before you can comment on or make changes to this bug.