Bug 526490 - [RHEL 5.3] Module [sis190] hangs the system if there is no working network attached to it
Summary: [RHEL 5.3] Module [sis190] hangs the system if there is no working network at...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.3
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Andy Gospodarek
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 15:25 UTC by Ahmad Fauzi
Modified: 2014-06-29 23:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 16:53:55 UTC


Attachments (Terms of Use)

Description Ahmad Fauzi 2009-09-30 15:25:42 UTC
Description of problem:
I've same problem at bug#176969 but I'm using RHEL 5.3.
If there is no network or a network failure during boot time, specific on network setup stage, the system hangs completely. An easy way to reproduce it is to not plug any network cable at all and wait it to try to boot and hang. It hapens with static IP, and specified Gateway, and dynamic IP, DHCP.


Version-Release number of selected component (if applicable):
kernel-2.6.18-128.el5

How reproducible:
Always

Steps to Reproduce:
1. Use a SiS 190/191 network adapter;
2. Let network service enable at boot time;
3. Do not connect any cable or, in my case, turn off your DSL modem;
4. Wait it to starts up.
  
Actual results:
The system hangs completely.


Expected results:
It could say that there is no network service avaiable but let the system going on with the rest of it.


Additional info:
I'm try the kernel by Linville but proved the same result

Comment 1 Andy Gospodarek 2009-09-30 19:38:45 UTC
The only upstream patch that looks relevant is this one:

commit c014f6c8f870271a8dcfe6e4139d6a651633aaf4
Author: Francois Romieu <romieu@fr.zoreil.com>
Date:   Thu Feb 15 23:37:29 2007 +0100

    sis190: RTNL and flush_scheduled_work deadlock
    
    Signed-off-by: Francois Romieu <romieu@fr.zoreil.com>
    Signed-off-by: Jeff Garzik <jeff@garzik.org>

Have you tried this with any other kernel (like a recent Fedora or other upstream kernel)?

The bug you referenced (bug 176969) was fixed with an update 2.6.15, so I suspect this code already has that fix.

Can you disable networking ('chkconfig network off') and see if you can reproduce this problem when you type 'service network start' after the system boots?

If that does hang the system, it would be nice to know when, so typing these commands one at a time and detecting which command caused the hang would be great.

# ifconfig eth0
# ethtool eth0
# ifconfig eth0 up
# ethtool eth0
# dhclient eth0
# ping -c 10 <some IP address on the network>

Thanks!


Note You need to log in before you can comment on or make changes to this bug.