Bug 526500 - smbk5pwd module is missing symbols
Summary: smbk5pwd module is missing symbols
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Zeleny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 517000
TreeView+ depends on / blocked
 
Reported: 2009-09-30 16:03 UTC by Ludwin Janvier
Modified: 2010-01-08 11:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 16:08:06 UTC
Type: ---


Attachments (Terms of Use)

Description Ludwin Janvier 2009-09-30 16:03:41 UTC
Description of problem:
smbk5pwd cannot be loaded in a ldap server : the error log shows it is missing "ldap_x_utf8s_to_wcs", which is defined in /usr/lib/libldap*


Version-Release number of selected component (if applicable):
openldap-servers-2.4.15-5.fc11.i586

How reproducible:
Always


Steps to Reproduce:
0. (Not mandatory) get samba.schema and krb5-kdc.schema in your /etc/openldap/schema and include them in your slapd.conf
1. Add "moduleload smbk5pwd.la", "overlay smbk5pwd" in slapd.conf
2. Restart openldap
service ldap restart
or
sldapd -u ldap -d 255 -h ldap:///
3. Change a password, ie:
ldappasswd -x -D cn=admin,dc=example,dc=org -H ldap://localhost:389/ -W -S  uid=someuser,ou=People,dc=example,dc=org
  
Actual results:
$ ldappasswd ...
New password: 
Re-enter new password: 
Enter LDAP Password: 
ldap_result: Can't contact LDAP server (-1)
$

ldap daemon is down
and no error in the log except the last line :
slapd: symbol lookup error: /usr/lib/openldap/smbk5pwd-2.4.so.2: undefined symbol: ldap_x_utf8s_to_wcs

Expected results:
ldappasswd to work, slapd to not die


Additional info:
BTW, I didn't find a package including krb5-kdc.schema, which is needed by smbk5pwd, according to its readme (/usr/share/doc/openldap-servers-2.4.15/README.smbk5pwd)

Comment 1 Jan Zeleny 2009-10-05 13:24:20 UTC
I've made a build which could fix the issue. Could you please test it for me? You can find packages on http://jzeleny.fedorapeople.org/packages/

Comment 2 Ludwin Janvier 2009-10-05 15:23:17 UTC
I'm only using x86 (32 bits) architecture. Could you rebuild these packages for this arch please ? I'll test them.

Comment 3 Jan Zeleny 2009-10-06 07:46:05 UTC
Here is a build for all architectures:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1729984

Comment 4 Ludwin Janvier 2009-10-06 14:44:20 UTC
Ok, it's working very well in Release 5.fc11. Thanks !
Is there a "fix committed" flag or do this bug has to be closed ?

Comment 5 Jan Zeleny 2009-10-06 16:08:06 UTC
The issue is resolved, I'm closing this bug. I will do the build and push it to updates ASAP.

Note: Although this issue is resolved, the fix is not very clean. If there is similar problem in another part of openldap, linking libldap should be done directly for slapd binary and not for smbk5pwd.so library. This solution however spares linking (of libldap) on startup of slapd when smbk5pwd isn't used.

Comment 6 Fedora Update System 2009-10-07 11:13:38 UTC
openldap-2.4.15-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openldap-2.4.15-6.fc11

Comment 7 Fedora Update System 2009-10-09 03:35:58 UTC
openldap-2.4.15-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.