Bug 526503 - software updater stalled on selinux install, and generates bugzilla warning now
software updater stalled on selinux install, and generates bugzilla warning now
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.0
All Linux
low Severity urgent
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 12:07 EDT by Duane Hellums
Modified: 2013-01-10 05:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-17 14:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Duane Hellums 2009-09-30 12:07:04 EDT
Description of problem:  I was running software updater, and half way through download it said it was told to stop (not by me...).  I restarted software updater, and it download all the updates again, and started installing them, until it got to the selinux package.  It then stalled and after 15 minutes or so the text in the update popup window disappeared.  I eventually closed it, and was warned that because it was not responding, it would cancel changes.  Sounds good, I hit OK.  After that, every time I try to launch software updater, I get the bugzilla report, and a graphic on my desktop about it.  Unsure what the status of updates are now, or how to proceed when it won't let me run the updater.  Here is the output from the bugzilla window.

Component: pirut
Summary: TBefbd0369 rhnplugin.py:243:__init__:AttributeError: can't set attribute

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 609, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 84, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 170, in doConfigSetup
    return self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 664, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 253, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 145, in init_hook
    repo = RhnRepo(channel)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 243, in __init__
    self.metadata_cookie = 'cookie'
AttributeError: can't set attribute

Local variables in innermost frame:
self: rhel-x86_64-server-5
channel: <up2date_client.rhnChannel.rhnChannel instance at 0x19742098>
urls: ['https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5']
Comment 1 James Antill 2009-09-30 12:30:59 EDT
It sounds like an update failed part way through, and you have mixed versions of yum/yum-rhn-plugin maybe a couple of others.

You might be able to run "package-cleanup --dupes" and "package-cleanup --problems", which might fix the problem.
If not run:

rpm -q yum yum-rhn-plugin yum-utils yum-metadata-parser

...and I'll tell you what to do.
Comment 2 Duane Hellums 2010-01-14 08:47:49 EST
I tried to run package-cleanup and got a file not found error.  Did a search on the entire system and couldn't find it.  Herewith the installed yum packages:

yum-3.2.8-9.el5_2.1
yum-3.2.22-20.el5
yum-rhn-plugin-0.5.3-12.el5_2.9
package yum-utils is not installed
yum-metadata-parser-1.1.2-2.el5
yum-metadata-parser-1.1.2-3.el5
Comment 3 James Antill 2010-01-14 10:38:16 EST
You have two versions of yum and yum-metadata-parser ... that's not good. Your best bet is probably to goto /var/cache/yum/* and rpm -Uvh the packages directly. Note that you might want to "yum clean metadata" after you've fixed those by hand.

yum-complete-transaction is in yum-utils, you'll probably be able to install it when you get just one version of yum/yum-metadata-parser installed.

Then you can run yum-complete-transaction and/or package-cleanup (but pay attention to what it says it's going to do, don't just blindly say yes if y-c-t wants to delete everything from your system).
Comment 4 Duane Hellums 2010-01-14 14:30:11 EST
[root@ packages]# rpm -q yum-metadata-parser
yum-metadata-parser-1.1.2-2.el5
yum-metadata-parser-1.1.2-3.el5

[root@ packages]# ls -al yum*
-rw-r--r-- 1 root root 1021109 Aug 27 15:26 yum-3.2.22-20.el5.noarch.rpm
-rw-r--r-- 1 root root   25948 Apr 22  2009 yum-metadata-parser-1.1.2-3.el5.x86_64.rpm
-rw-r--r-- 1 root root   57529 Aug 27 15:25 yum-rhn-plugin-0.5.4-13.el5.noarch.rpm

[root@ packages]# rpm -Uvh yum-metadata-parser-1.1.2-2.el5
error: open of yum-metadata-parser-1.1.2-2.el5 failed: No such file or directory

[root@ packages]# rpm -q yum-utils
package yum-utils is not installed

RPM thinks metadata-parser is installed, but it isn't anywhere on the system, and RPM won't let me uninstall it.  By the way, all of this is occurring on a system that is pretty much straight out of the box, and was updated using the menu-based software updater--I didn't install both version, so it must have been a system malfunction, not something "custom" we did on our end.
Comment 5 James Antill 2010-01-14 15:12:20 EST
> rpm -Uvh yum-metadata-parser-1.1.2-2.el5

 This should be:

 rpm -Uvh yum-metadata-parser-1.1.2-3.el5.x86_64.rpm

...you may also need to do:

 rpm -e yum-metadata-parser-1.1.2-2.el5.x86_64

...dito. with the yum problem.

> By the way, all of this is occurring on a
> system that is pretty much straight out of the box, and was updated using the
> menu-based software updater

 I understand, what almost certainly happened is that the transaction failed in the middle of an update. Maybe because the GUI updater crashed, maybe due to the selinux update, maybe for another reason.

 One you get yum/y-m-p working again, it is much easier to fix the rest of the problems.

 If you need any more help fixing yum/y-m-p if you phone support they should be able to walk you through it.
Comment 6 Chris Williams 2012-01-17 14:05:53 EST
This BZ has not been updated for 2 years.
Closing out as notabug. Feel free to contact Support if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.