Bug 526570 - Console font is not loaded as startup
Summary: Console font is not loaded as startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 21:12 UTC by Alexey Torkhov
Modified: 2010-01-28 00:53 UTC (History)
7 users (show)

Fixed In Version: 004-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-28 00:53:36 UTC
Type: ---


Attachments (Terms of Use)
Patch (563 bytes, patch)
2009-11-28 15:07 UTC, Alexey Torkhov
no flags Details | Diff

Description Alexey Torkhov 2009-09-30 21:12:44 UTC
Description of problem:
Console font is not loaded at startup - I see non-latin symbols as white squares.

Version-Release number of selected component (if applicable):
initscripts-8.99-1.x86_64
kernel-2.6.31.1-56.fc12.x86_64

Comment 1 Bill Nottingham 2009-10-01 17:33:41 UTC
Need the contents of:

/etc/sysconfig/i18n
your grub boot entry

Comment 2 Alexey Torkhov 2009-10-01 17:43:26 UTC
(In reply to comment #1)
> Need the contents of:
> 
> /etc/sysconfig/i18n
LANG="ru_RU.UTF-8"

> your grub boot entry  
title Fedora (2.6.31.1-56.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31.1-56.fc12.x86_64 ro root=/dev/mapper/VolGroup00-lv_rawhide  LANG=ru_RU.UTF-8 KEYBOARDTYPE=pc KEYTABLE=ru rhgb quiet
	initrd /initramfs-2.6.31.1-56.fc12.x86_64.img

Here it is.

Comment 3 Bill Nottingham 2009-10-01 17:56:58 UTC
You don't have a font set, although you should still get a default in that case. Is the rest of the console set up correctly?

Comment 4 Alexey Torkhov 2009-10-01 18:17:57 UTC
Yep, only non-latin (cyrillic) symbols are not shown.

Calling setsysfont makes it to work ok.

Comment 5 Bill Nottingham 2009-10-01 18:23:44 UTC
If you are in the situation where it does not work, does "/lib/udev/console_init tty0" also fix it?

Comment 6 Alexey Torkhov 2009-10-01 18:33:27 UTC
Yes, it does, for current console (from which command was issued).

Comment 7 Alexey Torkhov 2009-10-06 06:23:32 UTC
Strange, but problem is gone.

Comment 8 Bill Nottingham 2009-10-06 16:20:38 UTC
OK. I couldn't reproduce it here. Closing.

Comment 9 Alexey Torkhov 2009-10-22 07:18:10 UTC
Hmm... even more strange, but the problem shows up again :/

Comment 10 Alexey Torkhov 2009-10-29 11:01:30 UTC
I think, I've find why it sometimes works, and sometimes doesn't.
If a key pressed at start to hide plymouth splash and show boot process, it loads font. But, if plymouth splash stays, it doesn't.

Comment 11 Bill Nottingham 2009-10-30 01:09:34 UTC
Sounds like an ordering bug in dracut - the console_init stuff needs to run before graphics drivers & plymouth are initialized.

Comment 12 Harald Hoyer 2009-10-30 08:41:46 UTC
If you add SYSFONT=<fontname> to the kernel command line, the font should be loaded (like in /etc/sysconfig/i18n without the ").

Comment 13 Serge Pavlovsky 2009-11-06 06:03:39 UTC
i have SYSFONT in cmldine
if i press esc immediately after plymouth shows picture, something  strange happens with screen, but after pressing esc again fiew times i see 'starting udev' with right font
if i press esc after a while, i can only see boxes instead of russian letters

Comment 14 Bug Zapper 2009-11-16 13:08:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 15 Alexey Torkhov 2009-11-28 15:07:45 UTC
Created attachment 374420 [details]
Patch

(In reply to comment #11)
> Sounds like an ordering bug in dracut - the console_init stuff needs to run
> before graphics drivers & plymouth are initialized.  

Right. Attached workaround patch fixes the problem.

Comment 16 Fedora Update System 2010-01-26 10:48:52 UTC
dracut-004-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dracut-004-4.fc12

Comment 17 Fedora Update System 2010-01-27 01:06:03 UTC
dracut-004-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dracut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1088

Comment 18 Fedora Update System 2010-01-28 00:51:23 UTC
dracut-004-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.