Bug 526586 - ZTE MF626 not working with NetworkManager/ModemManager
ZTE MF626 not working with NetworkManager/ModemManager
Status: CLOSED DUPLICATE of bug 515412
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 18:13 EDT by Paul Ionescu
Modified: 2009-10-11 06:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 11:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug info from NM/MM (5.28 KB, text/plain)
2009-09-30 18:13 EDT, Paul Ionescu
no flags Details
modemmanager --debug (12.83 KB, text/plain)
2009-09-30 19:17 EDT, Paul Ionescu
no flags Details
wvdial log (1.08 KB, application/octet-stream)
2009-09-30 19:45 EDT, Paul Ionescu
no flags Details

  None (edit)
Description Paul Ionescu 2009-09-30 18:13:26 EDT
Created attachment 363253 [details]
debug info from NM/MM 

Description of problem:
I cannot use the ZTE MF626 usb modem with NetworkManager/ModemManager.
Tested with Fedora 10,11,rawhide.
The service is 3G from ZAPP/Romania.


Version-Release number of selected component (if applicable):
Tried with NetworkManager 7 (several versions), and NM/MM from Rawhide.

How reproducible:
Always.

Steps to Reproduce:
1.plug ZTE MF626 usb modem
2.wait a little to settle down and eject the CD
3.new GSM modem is found by NM
4.select to connect from nm-applet, the led on the modem goes from orange to green but it does not connect (should be close thou)

Additional info:
some debug info from NM/MM is attached.
Comment 1 Paul Ionescu 2009-09-30 19:17:14 EDT
Created attachment 363262 [details]
modemmanager --debug

output from modemmanager with --debug option

as you can see, it goes pretty far with connection, but fails in the end.

One more thing, when I try to connect for the first time, it fails right away, when I try the second time, it does something, the led goes green, still does something, and then it fails after a while.
Comment 2 Paul Ionescu 2009-09-30 19:45:13 EDT
Created attachment 363264 [details]
wvdial log

This is the output log of a working wvdial configuration with the same card.
(I modified the PIN string for security reasons)

The wvdial.conf is plain vanilla:

[Dialer Defaults]
Init2 = ATZ E0 V1 X4 &C1 +CMEE=1;+CFUN=1;
Modem Type = Analog Modem
New PPPD = yes
ISDN = 0
Username = zapp
Init1 = AT+CPIN="6262"
Password = zapp
Modem = /dev/ttyUSB2
Baud = 9600
Phone = *99#
Comment 3 Peter Robinson 2009-10-02 11:11:28 EDT
Its the same issue as the MF636 and other ZTE modems. Can you please provide the output of lsusb for the device as well.

*** This bug has been marked as a duplicate of bug 515412 ***
Comment 4 Paul Ionescu 2009-10-02 13:22:53 EDT
Hi Peter,

Here is the lsusb before usb_modeswitch:

Bus 002 Device 007: ID 19d2:2000 ONDA Communication S.p.A. 

and after usb_modeswitch:

Bus 002 Device 008: ID 19d2:0031 ONDA Communication S.p.A. 


However, I don't think my bug report is a duplicate of 515412, because my modem is recognized by ModemManager and NetworkManager as you can see from the attached logs.
I am able to create a new broadband connection with nm-applet and the process goes pretty far in talking with the modem.

Please see the text from the attachment_id = 363262 to see the detailed communication between modem-manager and the modem.
Comment 5 LukasHetzi 2009-10-11 06:25:00 EDT
I can confirm this problem too, tested with F11 and latest updates, provider is Yesss from Austria.

I also don't think that this is a duplicate of 515412, because I can see the 'Create a new ....connection' option in the NetworkManager applet
Comment 6 LukasHetzi 2009-10-11 06:57:38 EDT
Hm, strange, my girlfriend got it working on her notebook out of the box..
Sorry for the early report, I'll test it again next week.

Note You need to log in before you can comment on or make changes to this bug.