This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526594 - Content of "Install New Software" component list invisible after refresh
Content of "Install New Software" component list invisible after refresh
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 19:02 EDT by Michel Alexandre Salim
Modified: 2010-09-01 08:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-01 08:42:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2009-09-30 19:02:40 EDT
Description of problem:
I followed the instructions at these URLs:

http://developer.android.com/sdk/1.6_r1/installing.html
http://developer.android.com/sdk/1.6_r1/installing.html#Troubleshooting

but cannot get the ADT installed. Adding the update site works, and the connectivity test works as well, but after selecting the update site, no components ever appeared as install choices.

Using the troubleshooting approach, the exact same result happened: installing from an archive, no choices are available.

Version-Release number of selected component (if applicable):
eclipse-platform-3.5.0-2.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Follow instructions to install ADT
  
Actual results:
No available components

Expected results:
ADT should be listed, and should be installable


Additional info:
Comment 1 Michel Alexandre Salim 2009-09-30 20:20:46 EDT
Correction: the problem is that, after selecting an update repository, the refresh of the box showing the available components cause the content to be invisible (no text, no drop-down button, nothing). The tooltips for each item are still visible, and by blindly navigating using the keyboard one could actually get things installed.

The same problem occurs with upstream Eclipse (J2EE/x86_64), so this might need to be filed upstream. I had the same problem installing JGit -- though something I did earlier somehow made the list of packages visible once (not reproducible).

I tried switching the GTK theme from Nodoka to Clearlooks, and both exhibited the same problem. Could this be an SWT problem?
Comment 2 Andrew Overholt 2009-10-02 10:05:04 EDT
I can't say I've ever experienced this problem but if you can reproduce with upstream, I'm sure they'd appreciate the bug report.

Note that with our RPMs, we can't have a default list of update sites due to:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=249133
Comment 3 Bug Zapper 2009-11-16 08:08:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Andrew Overholt 2010-08-23 15:39:38 EDT
Is this still a problem?  There was a GTK bug with the list not refreshing ... maybe that was the issue at the time?

Note You need to log in before you can comment on or make changes to this bug.