Bug 52664 - Installer crashes with ks=floppy option
Installer crashes with ks=floppy option
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 15:48 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-27 15:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-27 15:48:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
In trying to duplicate an existing system (identical config) I tried to use
the  "linux ks=floppy" option at the LILO prompt.  It read the loppy and
started anaconda and crashes (output saved on disk and is below).  The
install worked fine when I simply did an install from the CDs and didn't
use kickstart at all.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1698, in
doInstall
    self.getCompsList()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 770, in
getCompsList
    self.updateInstClassComps ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 811, in
updateInstClassComps
    self.selectPackage(n)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 826, in
selectPackage
    raise ValueError, str
ValueError: package howto is not available

Local variables in innermost frame:
package: howto
str: package howto is not available
self: <todo.ToDo instance at 81f1aa8>


... more information in file (if it helps)
Comment 1 Brent Fox 2001-08-27 16:30:27 EDT
It looks like your kickstart file includes a package called 'howto' that doesn't
exist.  The installer is trying to install that package, and it fails when the
package isn't found.  There was no 'howto' package distributed with 7.1.  If you
remove this from the %packages section of the kickstart file, things should work
from there.

Please reopen this bug report if this doesn't fix the problem.

Note You need to log in before you can comment on or make changes to this bug.