Bug 526649 - `yum check-update` ends with rc = 100
Summary: `yum check-update` ends with rc = 100
Keywords:
Status: CLOSED DUPLICATE of bug 544314
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-10-01 09:50 UTC by Jan Hutař
Modified: 2012-04-02 11:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-02 11:47:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2009-10-01 09:50:21 UTC
Description of problem:
Upgrade documentation says to upgrade using command which do not work with current yum.


Version-Release number of selected component (if applicable):
rhn-upgrade-5.3.0.24-1.el5sat
rhn-upgrade-5.3.0.24-1.el4sat
yum-3.2.22-20.el5
yum-rhn-plugin-0.5.4-13.el5


How reproducible:
always


Steps to Reproduce:
1. ensure there are upgrades available
2. # yum check-update && yum upgrade


Actual results:
System is not upgraded because `&& ...` will not be performed.

> 6. Update the RHN Satellite (connected RHN Satellites only):
>    up2date -p && up2date -uf (on 4AS)
>    yum check-update && yum upgrade (on 5 Server or 5 Client)


Expected results:
Maybe something like:

> 6. Update the RHN Satellite (connected RHN Satellites only):
>    up2date -p && up2date -uf (on 4AS)
>    yum check-update; yum upgrade (on 5 Server or 5 Client)

or maybe:

>    rhn-profile-sync && yum upgrade (on 5 Server or 5 Client)


Additional info:
# yum check-update
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
autofs.x86_64          1:5.0.1-0.rc2.131.el5_4.1 rhel-x86_64-server-5
openssh.x86_64         4.3p2-36.el5_4.2          rhel-x86_64-server-5
openssh-clients.x86_64 4.3p2-36.el5_4.2          rhel-x86_64-server-5
openssh-server.x86_64  4.3p2-36.el5_4.2          rhel-x86_64-server-5
tzdata.noarch          2009m-1.el5               rhel-x86_64-server-5
# echo $?
100

Comment 1 Milan Zázrivec 2012-04-02 11:47:44 UTC

*** This bug has been marked as a duplicate of bug 544314 ***


Note You need to log in before you can comment on or make changes to this bug.