Bug 52671 - up2date fails to resolve dependencies for openssl (needs to pull in openssl095a)
up2date fails to resolve dependencies for openssl (needs to pull in openssl095a)
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-08-27 17:07 EDT by Need Real Name
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-02 12:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-27 17:07:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5 i686; en-US; rv:0.9.1)

Description of problem:
Using up2date to update openssl, I get an error regarding failing
dependencies. Many, many packages depend on libcrypt.so.0 (symlink to
libcrypt.so.0.9.5) and libssl.so.0 (ditto - to libssl.so...).
It seems you fixed this by providing an updated 0.9.5, and also the newer
openssl 0.9.6. The developers seem to be on a pre 1.0 kick, so it is
symlinked to lib(crypt|ssl).so.1 instead.
This breaks dependencies.

OK - the problem - simply put, up2date should find the dependencies and
pull in the openssl095a package to satisfy them.

After I struggled for a time and ftp'd to rawhide, I discovered the
openssl095a package. up2date openssl095a, up2date -u solved everything.

I thought it was just me, but the up2date -u automatically solved another
dependency with a similar issue - it pulled in the package openldap12
because the new openldap package breaks dependencies.

Why can't it do that for openssl and openssl095a?

Steps to Reproduce:
1. base RH7.1 system plus up2date as of 7/01
2. up2date -u on 8/27/01 or after (probably as early as 8/23)

Actual Results:  Fails to update - says unable to resolve dependencies
automatically - because of dependencies on libcrypt.so.0 and libssl.so.0

Expected Results:  Should automatically pull in openssl095a.
Comment 1 Need Real Name 2001-08-27 17:10:47 EDT
Workaround - For those of you also stuck with this.

Like I said above:
# up2date openssl095a
# up2date -u

Or, simply:
# up2date openssl095a openssl openssl-devel

Then update whatever else you want.
Comment 2 Jay Turner 2001-08-28 11:19:13 EDT
OK, the only way that I see this happening on a base 7.1 installation is if
openssl095a didn't get installed to begin with, then something got queued for
installation which depended on the functionality provided by the compat package.
 Going to attempt this in the lab and see what happens.
Comment 3 Need Real Name 2001-09-02 12:07:27 EDT
Um... make that RH7.0. I have two servers, one with RH7.0 and one with RH7.1. 
I'm having the problem with the 7.0 box, but the 7.1 box updates fine.
Comment 4 Adrian Likins 2002-05-08 18:19:08 EDT
This should be fixed with the current errata versions of up2date.

Note You need to log in before you can comment on or make changes to this bug.