Bug 526784 - RFE: yum-complete-transaction should have an option to iterate over all outstanding transactions
Summary: RFE: yum-complete-transaction should have an option to iterate over all outst...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-01 18:20 UTC by John Ellson
Modified: 2018-07-18 21:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 21:31:49 UTC
Type: ---


Attachments (Terms of Use)

Description John Ellson 2009-10-01 18:20:08 UTC
Description of problem:
yum-complete-transaction should have an option to iterate over all outstanding transactions.

If yum has been failing, e.g. from a cron job, there can be many outstanding transactions to clean up.  It would be a lot less painful if there was an option on yum-complete-transactions to iterate over them all in an unattended fashion.

Bonus points for doing it efficiently, perhaps by iteration the transactions in one pass, and updating the rpms in a single merged pass afterwards.

Version-Release number of selected component (if applicable):
yum-utils-1.1.23-3.fc12.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Simpler yum administration.

Additional info:

Comment 1 seth vidal 2010-01-12 21:13:02 UTC
the best bet is to run: yum-complete-transaction --cleanup-only 

but you can also go into the /var/lib/yum dir and remove the files manually.

Comment 2 Daniel Mach 2018-07-18 21:31:49 UTC
yum and related packages are no longer actively developed.
They are being replaced with dnf, dnf-utils, etc.

I'm closing this bug because it's most likely never going to be fixed.
If you still consider your bug report important, reopen it, please.

Comment 3 Daniel Mach 2018-07-18 21:34:23 UTC
yum and related packages are no longer actively developed.
They are being replaced with dnf, dnf-utils, etc.

I'm closing this bug because it's most likely never going to be fixed.
If you still consider your bug report important, reopen it, please.


Note You need to log in before you can comment on or make changes to this bug.